summaryrefslogtreecommitdiffstats
path: root/multimedia/realplayer/realplayer.SlackBuild
blob: 47f554354d2fa891b27496ac8717f3cd1f33c826 (plain)
#!/bin/sh

# Copyright 2010  Binh Nguyen <binhnguyen@fastmail.fm>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=realplayer
VERSION=11.0.2.1744    # Ephemeral version
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

ARCH=i386

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# Get the real version
REAL_VER=$(ar p RealPlayer11GOLD.deb control.tar.gz | tar xzO ./control | grep Version | cut -d\  -f2 | cut -d- -f1)

if [ "$VERSION" != "$REAL_VER" ]; then
  printf "\nThis script was made for $VERSION, but you seem to have $REAL_VER.\n\n"
  exit 1
fi

set -eu

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $PKG
ar p $CWD/RealPlayer11GOLD.deb data.tar.gz | gzip -d | tar xv

chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# Remove stuff we don't need
rm rules.log

# Link the main binary to /usr/bin
mkdir -p $PKG/usr/bin
ln -sf /opt/real/RealPlayer/realplay $PKG/usr/bin/realplay

# Link program shortcut to /usr/share/applicaions
mkdir -p $PKG/usr/share/applications
ln -sf /opt/real/RealPlayer/share/realplay.desktop $PKG/usr/share/applications/realplay.desktop

# Link icon to /usr/share/pixmaps
mkdir -p $PKG/usr/share/pixmaps
ln -sf /opt/real/RealPlayer/share/realplay.png $PKG/usr/share/pixmaps/realplay.png

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
mv $PKG/usr/share/doc/realplay/* $PKG/usr/doc/$PRGNAM-$VERSION
rm -rf $PKG/usr/share/doc
ln -sf /opt/real/RealPlayer/README $PKG/usr/doc/$PRGNAM-$VERSION/README
ln -sf /opt/real/RealPlayer/LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}