summaryrefslogtreecommitdiffstats
path: root/multimedia/gst-gnome-vfs/gst-gnome-vfs.SlackBuild
blob: 3081677fadb17aff32f7a04aed35db92d395a924 (plain)
#!/bin/sh
# Slackware build script for gst-gnome-vfs
# Written by Marco Cecchetti (mrc.ildp@gmail.com)

PRGNAM=gst-gnome-vfs
VERSION=${VERSION:-0.10.23}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
    # Unless $ARCH is already set, use uname -m for all other archs:
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}	
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e  
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT

cd $TMP
rm -rf gst-plugins-base-$VERSION
tar xvf $CWD/gst-plugins-base-$VERSION.tar.?z*
cd gst-plugins-base-$VERSION
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --enable-static=no \
  --disable-nls \
  --disable-debug \
  --disable-examples \
  --with-plugins \
  --disable-x \
  --disable-xvideo \
  --disable-gst_v4l \
  --disable-alsa \
  --disable-cdparanoia \
  --disable-gio \
  --disable-libvisual \
  --disable-ogg \
  --disable-pango \
  --disable-theora \
  --disable-vorbis \
  --build=$ARCH-slackware-linux 

  make

mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/gstreamer-0.10
cp ext/gnomevfs/.libs/libgstgnomevfs.so $PKG/usr/lib${LIBDIRSUFFIX}/gstreamer-0.10
cp ext/gnomevfs/.libs/libgstgnomevfs.la $PKG/usr/lib${LIBDIRSUFFIX}/gstreamer-0.10

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}