summaryrefslogtreecommitdiffstats
path: root/misc/tal/tal.SlackBuild
blob: de0560177b146b6bc4bae10ecee03ec5c46090ae (plain)
#!/bin/bash

# Slackware build script for tal

# Copyright 2022-2023 B. Watson <urchlay@slackware.uk>
# Copyright 2018 Donald Cooley South Haven, Indiana USA
# Written by Peter Wang <email removed>

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20230222 bkw: BUILD=3
# - finally update EMAIL and MAINTAINER in .info file (derp).
# - make sure $PKG/usr/bin exists before trying to install there.
# - fix compile warnings.
# - add example to README.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=tal
VERSION=${VERSION:-1.9}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# 20230223 bkw: fix a potential bug: uninitialized variable.
# Honestly this isn't much of a fix: if you have files called foo and
# bar, and you run "tal foo bar baz" (which is an error, it doesn't
# take 3 filenames), the outfile_existed variable is supposed to
# prevent tal from deleting bar if it already existed. Which it
# does. But instead it truncates bar to 0 bytes, which is actually
# worse than deleting it IMO. However, I'm leaving the logic as-is.
# This just makes it always work as the author intended.
sed -i '/int outfile_existed/s,;, = 0;,' tal.c

# 20230222 bkw: WTF was the -ansi flag being passed? All it did
# was cause strdup()'s prototype to disappear (implicit declaration
# warning, plus int-to-pointer cast warnings).
make CFLAGS="-Wall $SLKCFLAGS" tal

mkdir -p $PKG/usr/bin
install -s -m0755 $PRGNAM $PKG/usr/bin

mkdir -p $PKG/usr/man/man1
gzip -9c tal.1 > $PKG/usr/man/man1/tal.1.gz

# INSTALL contains a vim tip so let's extract it.
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
sed -n '/^For use with vim/,$p' INSTALL > $PKGDOC/vimtip.txt
cp -a LICENSE $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE