summaryrefslogtreecommitdiffstats
path: root/misc/g810-led/g810-led.SlackBuild
blob: 621fbaaf3c3e0c4add4e42d8f1cf39f0e1bd42f6 (plain)
#!/bin/sh

# Copyright 2020  Patrick Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=g810-led
VERSION=${VERSION:-0.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

# Set this to anything other than "NO" to install the shared library and
# development files. I'm not aware of anything that can make use of these
# at this time. Also, the library will not compile on Slackware 14.2, though
# it does compile on -current.
DEVEL=${DEVEL:-NO}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+

# Patch the following issues with the makefile:
# - errors when systemd is not present
# - $(DESTDIR) missing in a few places
# - create relative, not absolute symlinks
# - create and install the shared library with a proper soname
# - don't install the udev rules
patch -p1 < $CWD/g810-led.makefile.patch

# Fix libdir:
sed -i "s|libdir?=\$(PREFIX)/lib|libdir?=\$(PREFIX)/lib${LIBDIRSUFFIX}|g" makefile

make bin LIB=libusb
make install DESTDIR=$PKG
if [ ! "$DEVEL" = "NO" ]; then
  make lib LIB=libusb
  make install-lib DESTDIR=$PKG
  make install-dev DESTDIR=$PKG
  # Fix permissions on shared library:
  chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/libg810-led.so.*
fi

# Strip binaries:
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# Don't clobber an existing configuration:
mv $PKG/etc/g810-led/profile $PKG/etc/g810-led/profile.new
mv $PKG/etc/g810-led/reboot $PKG/etc/g810-led/reboot.new

# Install the udev rules manually, filtering out the part that seems broken:
mkdir -p $PKG/lib/udev/rules.d
cat udev/g810-led.rules | grep -v SUBSYSTEMS > $PKG/lib/udev/rules.d/g810-led.rules

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  CONTRIBUTING* CONTRIBUTORS* INSTALL* LICENSE* PROFILES* README* \
  $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/g810-led.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/g810-led.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}