summaryrefslogtreecommitdiffstats
path: root/misc/figlet-contributed/figlet-contributed.SlackBuild
blob: 2b9c94975cf57c933dc11c8825b5406d713e958a (plain)
#!/bin/sh

# Slackware build script for figlet-contributed

# Copyright 2017 Erik Falor Logan, UT, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=figlet-contributed
VERSION=${VERSION:-1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

FONTS="$(printf $PRGNAM | cut -d- -f2-)"

ARCH=noarch

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $FONTS
tar xvf $CWD/$FONTS.tar.gz
cd $FONTS

if [ "${OBANNER_ALL:-no}" = "yes" ]; then
	tar xvf Obanner.tgz
	ln -f Obanner/README Obanner.README
	ln -f Obanner/*.flf .
else
	tar xvf Obanner-canon.tgz
	ln -f Obanner-canon/README Obanner.README
	ln -f Obanner-canon/*.flf .
fi

chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

if [ "${C64:-no}" = "yes" ]; then
	ln -f C64-fonts/*.flf .
fi

if [ "${BDF:-no}" = "yes" ]; then
	ln -f bdffonts/README bdffonts.README
	ln -f bdffonts/*.flf .
	mkdir -p $PKG/usr/bin
	cp bdffonts/bdf2flf.pl $PKG/usr/bin/bdf2flf.pl
	chmod 755 $PKG/usr/bin/bdf2flf.pl
fi

mkdir -p $PKG/usr/share/figlet
cp *.flf *.flc $PKG/usr/share/figlet

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp *README $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}