summaryrefslogtreecommitdiffstats
path: root/libraries/agar/agar.SlackBuild
blob: 70765b483691e227f0a8ed514fbc94bb021daa16 (plain)
#!/bin/bash

# Slackware build script for agar

# Written by B. Watson (urchlay@slackware.uk)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# Notes: This thing chooses to build itself with clang rather than
# gcc. Unless that actually causes a problem, I'm not overriding it.
# If you really want to build with gcc, use: export CC=gcc

# 20230626 bkw: BUILD=2, install shared libs +x

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=agar
SRCNAM=libagar
VERSION=${VERSION:-1.7.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
elif [ "$ARCH" = "aarch64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# patch from upstream git, dike out some code that requires a newer
# sdl2 than we have on 15.0 (needs 2.0.22, we have 2.0.20).
patch -p1 < $CWD/463ea0a-sdl_hint_mouse_auto_capture.diff

# 'make install' is slightly broken, this directory must already
# exist:
mkdir -p $PKG/usr/bin

# prevent 'make install' from running ldconfig multiple times (or at all).
sed -i 's,/sbin/ldconfig;,/bin/true;,' mk/build.lib.mk

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --disable-static \
  --build=$ARCH-slackware-linux

make
make -j1 install DESTDIR=$PKG   # yes, the -j1 is needed.

chmod +x $PKG/usr/lib*/*.so.*.*.*
strip $PKG/usr/lib*/*.so.*.*.*  # no 'make install-strip'.

# since we couldn't stop static libs from being installed, delete them here,
# along with useless .la files.
rm -f $PKG/usr/lib*/*.{a,la}

if [ "$LIBDIRSUFFIX" = "64" ]; then
  # fix the pkg-config stuff...
  mv $PKG/usr/lib/pkgconfig $PKG/usr/lib64/pkgconfig
  rmdir $PKG/usr/lib
  sed -i '/^libdir/s,/lib,/lib64,g' $PKG/usr/lib64/pkgconfig/*.pc
fi

# it creates all the man subdirs, even though it uses only one of them.
find $PKG/usr/man -type d -a -empty | xargs rmdir
gzip -9 $PKG/usr/man/man*/*

PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
rm -f INSTALL.md
mkdir -p $PKGDOC
cp -a LICENSE* OFL.txt *.md $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE