summaryrefslogtreecommitdiffstats
path: root/games/wargus/wargus.SlackBuild
blob: 7d00b7dface6eb471a5bafb1a04ac52a257390fb (plain)
#!/bin/bash

# Slackware build script for wargus

# Written by B. Watson (urchlay@slackware.uk)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20211119 bkw: BUILD=2
# - fix -current build.
# - remove ffmpeg2theora dep.
# - new-style icons.
# - add README note about why this is stuck at an old version.
# 20180915 bkw: updated for v2.4.1

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=wargus
VERSION=${VERSION:-2.4.1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# 20211119 bkw: get rid of ffmpeg2theora dep, just call ffmpeg directly.
patch -p1 < $CWD/wartool.ffmpeg.diff

# 20150511 bkw: upstream hardcodes a particular soundfont but
# doesn't ship it. We'll use the one from fluid-soundfont.
sed -i \
  's,music/TimGM6mb.sf2,/usr/share/sounds/sf2/FluidR3_GM.sf2,' \
  scripts/stratagus.lua

SLKCFLAGS+=" -I/usr/include/harfbuzz"
mkdir -p build
cd build
  cmake \
    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_BUILD_TYPE=Release ..
  make
  make install/strip DESTDIR=$PKG
cd ..

mkdir -p $PKG/usr/man/man6
for i in doc/*.6; do
  gzip -9c < $i > $PKG/usr/man/man6/$( basename $i ).gz
done

for px in 16 32 48 64; do
  size=${px}x${px}
  dir=$PKG/usr/share/icons/hicolor/$size/apps
  mkdir -p $dir
  convert -resize $size $PRGNAM.png $dir/$PRGNAM.png
done

rm $PKG/usr/share/pixmaps/*
ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png

# attempt to extract the game data files
CONTAINS="does not contain"
REDIST="This binary package may be redistributed."
if [ -n "$GAMEDATA" ]; then
  WARTOOL=$PKG/usr/bin/wartool \
    sh $CWD/extract-warcraft2 \
      "$GAMEDATA" \
      $PKG/usr/share/games/stratagus/$PRGNAM
  if [ "$?" = "0" ]; then
    CONTAINS=contains
    REDIST="DO NOT REDISTRIBUTE this binary package."
  fi
fi

# include the extractor script in the package, either way
install -m0755 -oroot -groot $CWD/extract-warcraft2 $PKG/usr/bin

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp $CWD/README_SBo.txt COPYING* README* doc/changelog doc/*txt \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
sed -e "s,@CONTAINS@,$CONTAINS," -e "s,@REDIST@,$REDIST," $CWD/slack-desc \
  > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE