summaryrefslogtreecommitdiffstats
path: root/games/pcgen/pcgen.SlackBuild
blob: eafe288ec492b37a0731312edfcd4dedf71235ee (plain)
#!/bin/bash
# Slackware build script for pcgen
# Copyright 2017 klaatu @ member.fsf.org
#
# GNU All-Permissive License
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
# notice and this notice are preserved.  This file is offered as-is,
# without any warranty.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=pcgen
VERSION=${VERSION:-"6.06.01"}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

ARCH="noarch"

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
unzip $CWD/"$PRGNAM"-"$VERSION"-full.zip -d $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

mkdir -p $PKG/opt/
mv $PRGNAM $PKG/opt/$PRGNAM

# patch for launcher
tr -d '\r' < $PKG/opt/$PRGNAM/$PRGNAM.sh > $PKG/opt/$PRGNAM/$PRGNAM-launch.sh
mv $PKG/opt/$PRGNAM/$PRGNAM-launch.sh $PKG/opt/$PRGNAM/$PRGNAM.sh

# desktop file, added to SlackBuild for convenience
mkdir -p $PKG/usr/share/applications/
cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications/

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}