summaryrefslogtreecommitdiffstats
path: root/games/o2em/o2em.SlackBuild
blob: 7eb2119b4d467eb3357c5da7c8e4bb57f53d835d (plain)
#!/bin/bash

# Slackware build script for o2em

# Written by B. Watson (urchlay@slackware.uk)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20211102 bkw: BUILD=2
# - fix -current build.
# - binaries in /usr/games.
# - man page in section 6.
# - /usr/share/o2em => /usr/share/games/o2em.
# - convert docs to utf-8.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=o2em
VERSION=${VERSION:-1.18}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
else
  SLKCFLAGS="-O2"
fi

set -e

SRC=${PRGNAM}${VERSION/./}src

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRC
unzip -L $CWD/$SRC.zip
cd $SRC
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# Patch does this:
# make makefile.linux use allegro-config to find cflags/libs for allegro
# make various source files #include <errno.h>
# add SLKCFLAGS support to makefile.linux
patch -p1 < $CWD/compile_fix.diff

# Patch fixes wordsize assumptions on x86_64 and makes no difference on x86
patch -p1 < $CWD/wordsize.diff

cd src
make -f makefile.linux SLKCFLAGS="$SLKCFLAGS -fcommon"

mkdir -p $PKG/usr/games $PKG/usr/libexec \
         $PKG/usr/share/pixmaps $PKG/usr/share/icons/hicolor/64x64/apps
install -s -m0755 -oroot -groot dis48 $PKG/usr/games
install -s -m0755 -oroot -groot $PRGNAM $PKG/usr/libexec/$PRGNAM.bin
install -m0755 -oroot -groot $CWD/$PRGNAM.sh $PKG/usr/games/$PRGNAM
install -m0644 -oroot -groot $PRGNAM.png $PKG/usr/share/icons/hicolor/64x64/apps
ln -s ../icons/hicolor/64x64/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png

# There is no .desktop file because the emulator lacks a UI (if we
# launch it from the K menu, it prints an error on stdout and exits),
# and because ".bin" isn't much of a MIME type so we can't really
# do association (there's no magic header for the ROMs either).

mkdir -p $PKG/usr/man/man6
gzip -9c < $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz

mkdir -p $PKG/usr/share/games/$PRGNAM/{bios,voice}
unzip -L $CWD/o2mainsamp.zip -d $PKG/usr/share/games/$PRGNAM/voice

if [ -e $CWD/odyssey2.zip ]; then
  unzip $CWD/odyssey2.zip
  ROMFILE=o2bios.rom
elif [ -e $CWD/o2bios.rom ]; then
  ROMFILE=$CWD/o2bios.rom
elif [ -e $CWD/o2rom.bin ]; then
  ROMFILE=$CWD/o2rom.bin
fi

if [ -n "$ROMFILE" ]; then
  cat $ROMFILE > $PKG/usr/share/games/$PRGNAM/bios/o2rom.bin
  INCROM="includes"
else
  INCROM="does NOT include"
fi

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cd ../docs
for file in *; do
  sed 's/\r//g' < $file \
    | iconv -f iso-8859-1 -t utf-8 \
    > $PKG/usr/doc/$PRGNAM-$VERSION/$file
done
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
sed -e "s,@INCROM@,$INCROM," \
  $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE