summaryrefslogtreecommitdiffstats
path: root/games/dungeon/dungeon.SlackBuild
blob: ef639c011ac922219c9c24e6828a036d7e8ba087 (plain)
#!/bin/bash

# Slackware build script for dungeon

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20211006 bkw: BUILD=3, fix -current build.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=dungeon
VERSION=${VERSION:-19800808}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# NOTE: Nonstandard flags here.
# On 14.0, we used -O2 and everything was fine. On 14.1, using -O2
# causes a segfault on 'open mailbox' or 'examine mailbox'... but
# it doesn't happen with any of -O0 -O1 -O3. I'm not a Fortran guru,
# so I can't say whether the bug is in dungeon or gfortran. So to
# be on the safe side, this script uses -O0 to completely disable
# the optimizer.

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O0 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O0 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O0 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O0"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod 644 *

[ "${DEBUG:-no}" = "yes" ] && DFLAG='DEBUG=1'

make FFLAGS="$SLKCFLAGS -fallow-invalid-boz" $DFLAG
make install DESTDIR=$PKG

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
install -m0644 $CWD/$PRGNAM.jpg history read.me $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE