summaryrefslogtreecommitdiffstats
path: root/development/Xdialog/Xdialog.SlackBuild
blob: 8dc29a61a088cf7eea775bb8775b672be9ef484a (plain)
#!/bin/sh

# Slackware build script for Xdialog
# Written by slakmagik <slakmagik@gmail.com>
# Released under the WTFPL

PRGNAM=Xdialog
VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

NLS=${NLS:-disable}
# I do this so the script has a consistent interface, using 'enable' for both
# - and because passing '--without-gtk2' makes it compile for gtk2 as much as
# '--with; does(!) so you have to pass it nothing if you want gtk1.
if [ "$GTK2" = enable ]; then
  GTK2=--with-gtk2
else
  unset GTK2
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
# NEWS is a symlink to ChangeLog and the latter gets the wrong perms unless I
# exclude links from the tests
find . ! -type l \
  \( \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
  -o -perm 400 \) \) -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS -fgnu89-inline" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --mandir=/usr/man \
  --datadir=/usr \
  --$NLS-nls \
  $GTK2

make
make DESTDIR=$PKG install-strip

find $PKG/usr/man -type f -exec gzip -9 {} \;

cp -a [ABCINR]* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}