summaryrefslogtreecommitdiffstats
path: root/desktop/xpenguins-xtrathemes/xpenguins-xtrathemes.SlackBuild
blob: f1bf240bddbc0317b4d874daf09bfde17bb3daef (plain)
#!/bin/bash

# Slackware build script for xpenguins-xtrathemes

# Copyright <2018> <Michael Heras> <USA>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Modified by SlackBuilds.org:
# 20220207 bkw: BUILD=2
# - force ARCH=noarch.
# - add missing 'about' files (xpenguins segfaults without them).
# - add a couple of missing icons, resize a couple that were too big.
# - vastly simplify the script.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=xpenguins-xtrathemes
VERSION=${VERSION:-1.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
chown -R root:root .

# 20220207 bkw: someone left a backup file in the tarball:
rm -f themes/*/*~

# 20220207 bkw: these icons are just too big, they break the xpenguins UI.
for i in themes/Winnie_the_Pooh/pooh_sitter.png themes/Walking_Man/walkingman.png; do
  convert -resize 32x32 $i 1.png
  mv 1.png $i
done

SHAREDIR=$PKG/usr/share/xpenguins/
mkdir -p $SHAREDIR
cp -r themes $SHAREDIR

# 20220207 bkw: xpenguins will segfault if a theme has no about file.
# Went ahead and made icons, too.
for i in XSheep M.U.L.E.; do
  install -oroot -groot -m0644 $CWD/$i.about $SHAREDIR/themes/$i/about
  install -oroot -groot -m0644 $CWD/$i.png $SHAREDIR/themes/$i/$i.png
done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE