summaryrefslogtreecommitdiffstats
path: root/desktop/slack-wallpapers/slack-wallpapers.SlackBuild
blob: b14f901c8a6159dd72fcad56175314838e4f26bb (plain)
#!/bin/bash

# Slackware build script for slack-wallpapers

# Copyright 2012-2016 Petar Petrov slackalaxy@gmail.com
# Copyright 2017-2018 Skaendo <skaendo@linuxmail.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=slack-wallpapers
VERSION=${VERSION:-1.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

ARCH=noarch

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION

# I know this is probably some bad hackery, but it works.
# Suggestions are welcome.
for i in dated deviantart salix srbija; do
    if [ -e $CWD/$PRGNAM-$i-$VERSION.tar.gz ]; then
      tar xvf $CWD/$PRGNAM-$i-$VERSION.tar.gz
      mv ./*/wallpapers/* ./wallpapers
    else
      continue
    fi
done

chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

mkdir -p $PKG/usr/share/wallpapers
cp -vr ./wallpapers/* $PKG/usr/share/wallpapers

# Option to add backgrounds for LiLo.
if [ "${LILO:-no}" = "yes" ]; then
  mkdir -p $PKG/boot/images
  cp -vr ./lilo-images/* $PKG/boot/images
fi

# Option to add symlinks for MATE.
if [ "${MATE:-no}" = "yes" ]; then
  mkdir -p $PKG/usr/share/backgrounds/mate
  cd $PKG/usr/share/wallpapers/
  for i in *; do
    ln -s /usr/share/wallpapers/$i $PKG/usr/share/backgrounds/mate/.
  done
fi

# Option to add symlinks for XFCE.
if [ "${XFCE:-no}" = "yes" ]; then
  mkdir -p $PKG/usr/share/backgrounds/xfce
  cd $PKG/usr/share/wallpapers/
  for i in *; do
    ln -s /usr/share/wallpapers/$i $PKG/usr/share/backgrounds/xfce/.
  done
fi

cd $TMP/$PRGNAM-$VERSION

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog Contributing README \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE