summaryrefslogtreecommitdiffstats
path: root/desktop/docfetcher/docfetcher.SlackBuild
blob: 0b057d80967dbc3a81bc7d53d73900c944eeaee9 (plain)
#!/bin/sh

# Slackware build script for docfetcher

# Copyright 2018 Leonardo Citrolo, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=docfetcher
SRCNAM=DocFetcher
VERSION=${VERSION:-1.1.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

case "$ARCH" in
    i?86) ;;
  x86_64) ;;
       *) echo "$ARCH architecture is not supported"; exit 1 ;;
esac

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
unzip $CWD/$PRGNAM-$VERSION-portable.zip
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Set some sane defaults
zcat $CWD/paths.patch.gz | patch -p1

mkdir -p $PKG/usr/share/{$PRGNAM,applications} \
  $PKG/usr/bin
cp -a help img lang lib misc py4j \
  $SRCNAM-GTK2.sh $SRCNAM-GTK3.sh $PRGNAM-daemon-linux Readme.txt search.py \
  $PKG/usr/share/$PRGNAM

# Remove Mac OS X stuff
rm -f $PKG/usr/share/$PRGNAM/lib/swt/swt-4.6-cocoa-macosx-x86_64.jar

# Remove Windows stuff
rm -f $PKG/usr/share/$PRGNAM/lib/JIntellitype32.dll \
    $PKG/usr/share/$PRGNAM/lib/JIntellitype64.dll \
    $PKG/usr/share/$PRGNAM/lib/jnotify.dll \
    $PKG/usr/share/$PRGNAM/lib/jnotify_64bit.dll \
    $PKG/usr/share/$PRGNAM/lib/swt/swt-4.6-win32-win32-x86.jar \
    $PKG/usr/share/$PRGNAM/lib/swt/swt-4.6-win32-win32-x86_64.jar \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-1024.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-2048_64-bit-Java.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-256.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-4096_64-bit-Java.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-512.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-768.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM-8192_64-bit-Java.exe \
    $PKG/usr/share/$PRGNAM/misc/$SRCNAM.bat

# Remove unnecessary Arch-related stuff
if [ "$ARCH" = "x86_64" ]; then
    rm -f $PKG/usr/share/$PRGNAM/lib/libJXGrabKey32.so \
        $PKG/usr/share/$PRGNAM/lib/libjnotify32.so \
        $PKG/usr/share/$PRGNAM/lib/swt/swt-4.6-gtk-linux-x86.jar
else
    rm -f $PKG/usr/share/$PRGNAM/lib/libJXGrabKey64.so \
        $PKG/usr/share/$PRGNAM/lib/libjnotify64.so \
        $PKG/usr/share/$PRGNAM/lib/swt/swt-4.6-gtk-linux-x86_64.jar
fi

# Create launcher
cat > $PKG/usr/bin/$PRGNAM << EOF
#!/bin/sh

/usr/share/$PRGNAM/$SRCNAM-GTK3.sh "\$@"

EOF
chmod 755 $PKG/usr/bin/$PRGNAM

# Create destop entry
cat > $PKG/usr/share/applications/$PRGNAM.desktop <<EOF
[Desktop Entry]
Type=Application
Name=$SRCNAM
GenericName=$SRCNAM desktop search
Comment=$SRCNAM desktop search
Icon=/usr/share/$PRGNAM/img/squirrel.png
Exec=$PRGNAM
Path=/usr/share/$PRGNAM
Categories=Utility;
EOF

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}