summaryrefslogtreecommitdiffstats
path: root/audio/sonic-visualiser/sonic-visualiser.SlackBuild
blob: c00d915fa8aa047a17958edcea8caa817ba22266 (plain)
#!/bin/sh

# Slackware build script for sonic-visualiser

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20170312 bkw:
# - update for 3.0.1
# - parallel build seems OK, remove -j1 (again)
# - 3.0.1 requires a bleeding-edge capnproto (newer than the latest
#   release) so build a static one to link with. When capnproto.SlackBuild
#   gets updated past 0.5.3, this stuff can go away. The static capnproto
#   is used whether or not capnproto is installed on the system, and it's
#   not installed as part of the sonic-visualiser package.
# - add note to README about pulse and portaudio failures. I don't know
#   what's wrong yet, but jack-audio-connection-kit remains a hard dep
#   unless/until I figure it out.
# - upstream fixed the .desktop, remove my code that fixed the old one.
# - stop the unit tests from spamming /root

# 20160819 bkw:
# - parallel build is still broken, revert to -j1

# 20160806 bkw:
# - updated to 2.5, which means adding a qt5 dep.
# - fix parallel build.
# - according to INSTALL.txt, jack-audio-connection-kit is optional,
#   so I was going to remove it from REQUIRES. I tried building without it,
#   but the build failed, so it remains a hard dep for now.

# 20140913 bkw:
# - finally updated (from 1.9 to 2.3)
# - add man page
# - use png icon rather than svg
# - add MIME types for desktop integration
# - add realtime capabilities

PRGNAM=sonic-visualiser
VERSION=${VERSION:-3.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG $TMP/$PRGNAM
mkdir -p $TMP/$PRGNAM $PKG $OUTPUT

# use a top-level dir under $TMP for ease of cleanup.
cd $TMP/$PRGNAM

# Grrr. Upstream requires a git version of capnproto, newer than the
# latest release. They *really* should bundle it, or at least mention it
# in their README or INSTALL.txt, if they're going to depend on bleeding
# edge stuff... the only way to understand what's going on here is to
# actually read the comments in configure.ac. We have to build a static
# capnproto and force sonic-visualiser to use it.
LIBVER="${LIBVER:-86ce27924ceae700a70a00963aaab3766d26b348}"
LIBNAM=capnproto
LIBPREFIX=$TMP/$PRGNAM/$LIBNAM

rm -rf $LIBNAM-$LIBVER
tar xvf $CWD/$LIBNAM-$LIBVER.tar.gz
cd $LIBNAM-$LIBVER
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# following code borrowed & modified from capnproto.SlackBuild by
# Andre Barboza:
cd c++
  autoreconf -ivf
  CFLAGS="$SLKCFLAGS" \
  CXXFLAGS="$SLKCFLAGS" \
  ./configure \
    --prefix=$LIBPREFIX \
    --disable-shared \
    --enable-static \
    --build=$ARCH-slackware-linux

  # don't run ldconfig. not needed (a) because of --disabled-shared,
  # and (b) we're installing into a non-system directory anyway.
  sed -i '/^\t*ldconfig/d' Makefile

  make
  make install-strip
cd ..

# These will be used by sonic-visualiser's ./configure:
export PKG_CONFIG_PATH=$LIBPREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
export PATH=$LIBPREFIX/bin:$PATH

cd $TMP/$PRGNAM
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

QTDIR=$QT5DIR \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --build=$ARCH-slackware-linux

# fudge the test suite, all but 2 tests pass, and I think the error
# is in the test suite, not a real error in the code.
sed -i '375s,"aac","aac" || format == "mp3",' \
       svcore/data/fileio/test/AudioFileReaderTest.h

# Override $HOME since the unit tests insist on writing useless stuff
# there. In case the user's using ccache, this changes the cache dir,
# so we put it back like it was (no harm done if user not using ccache).
# Parallel build seems to work OK in 3.0.1. If not, uncomment the -j1
# and email me a bug report.
CCACHE_DIR=${CCACHE_DIR:-$HOME/.ccache} \
HOME=$( pwd ) \
  make # -j1

# There is a 'make install' in 3.0.1, but it's broken. It's not clear to
# me whether piper-convert should be installed: it's used by the unit
# tests, and mentioned in deploy/win32/sonic-visualiser.wxs but not in
# deploy/linux/deploy-deb.sh. I'll include it, just in case.
mkdir -p $PKG/usr/share/$PRGNAM/samples $PKG/usr/bin
install -m0644 samples/* $PKG/usr/share/$PRGNAM/samples
install -m0755 -s \
  $PRGNAM \
  vamp-plugin-load-checker \
  piper-vamp-simple-server \
  piper-convert \
  $PKG/usr/bin/

# man page borrowed from Debian
mkdir -p $PKG/usr/man/man1
gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz

mkdir -p $PKG/usr/share/applications
cat $PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop

# define MIME types to associate *.sv and *.svl
mkdir -p $PKG/usr/share/mime/packages
cat $CWD/$PRGNAM.xml > $PKG/usr/share/mime/packages/$PRGNAM.xml

mkdir -p $PKG/usr/share/pixmaps
cat icons/sv-128x128.png > $PKG/usr/share/pixmaps/sv-icon.png

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG CITATION COPYING README* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

# Only add capability stuff if not disabled:
if [ "${SETCAP:-yes}" = "yes" ]; then
  cat $CWD/setcap.sh >> $PKG/install/doinst.sh
  # Only allow execution by audio group
  chown root:audio $PKG/usr/bin/$PRGNAM
  chmod 0750 $PKG/usr/bin/$PRGNAM
fi

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}