summaryrefslogtreecommitdiffstats
path: root/audio/non/non.SlackBuild
blob: 088f7446204dbcbb6676448e193360213414d036 (plain)
#!/bin/bash
# Slackware build script for non
# Copyright 2019-22 Klaatu | Lawrence, NZ | Klaatu@member.fsf.org

# GNU All-Permissive License
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
# notice and this notice are preserved.  This file is offered as-is,
# without any warranty.

# 20230701 bkw: Modified by SlackBuilds.org, BUILD=2:
# - move docs to standard /usr/doc/$PRGNAM-$VERSION.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=non
VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

# determine what components we are building
if [ "X$PROJECT" != "X" ]; then
    DAW="--project=${PROJECT}"
else
    DAW="-p"
fi

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
TARBALL=$CWD/$PRGNAM-daw-v"$VERSION".tar.gz
if [ ! -e $TARBALL ] ; then
  TARBALL=$CWD/$PRGNAM-$PRGNAM-daw-v"$VERSION".tar.gz
fi
tar xvf $TARBALL
cd $PRGNAM
rm nonlib/nonlib

chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} + -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=c++11" \
./waf configure $DAW \
    --prefix=/usr \
    --libdir=/usr/lib${LIBDIRSUFFIX} \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --mandir=/usr/man \
    --docdir=/usr/doc/$PRGNAM-$VERSION
./waf
./waf install --destdir=$PKG

if [ "X$PROJECT" = "Xtimeline" -o "X$PROJECT" = "X" ]; then
    # fix nested bin directory
    mv $PKG/usr/bin/bin/import-ardour-session $PKG/usr/bin
    rmdir $PKG/usr/bin/bin/
fi

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# 20230701 bkw: Don't bother with README.build or README.packagers, they're
# not helpful to binary package users.
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
mv $PKG/usr/share/doc/* $PKGDOC
rm -rf $PKG/usr/share/doc
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE