summaryrefslogtreecommitdiffstats
path: root/audio/calf-ladspa/calf-ladspa.SlackBuild
blob: e925cc9e574e446ceb90b32d0eb3e3c8ab3fb798 (plain)
#!/bin/bash

# Slackware build script for calf-ladspa

# Written by B. Watson (urchlay@slackware.uk)

# 20211127 bkw: BUILD=2
# - rework README and slack-desc, remove mentions of JACK and DSSI.
# - move html docs to subdir.

# 20170706 bkw:
# - Patch source so it doesn't check for jack-audio-connection-kit or
#   fluidsynth. Previously they were required for the build to complete,
#   but the stuff that got built with support for them was being rm'ed
#   after make install (because the package only contains LADSPA plugins).
# - Remove jack-audio-connection-kit and fluidsynth from REQUIRES.
# - Add patch to support -current's gcc7. For now, it's commented out
#   in the SlackBuild, since 14.2 doesn't need it.

# 20151105 bkw:
# - Renamed to calf-ladspa. The main calf build is now for calf-0.0.60,
#   which lacks LADSPA support. Removed LV2 and standalone support, use
#   calf for that instead. Removed DSSI support, because I don't
#   think anyone's using it, and because it's non-trivial to install
#   the gui support files anywhere other than /usr/share/calf, which
#   would step on the main calf package.

# 20141030 bkw:
# Finally getting around to submitting this, there have been no code
# changes upstream since 20140308.

# 20140308 bkw:
# - Switched to falkTX's KXStudio fork of CALF. falkTX doesn't do release
#   tarballs, so this is a git checkout from 20140308.
# - Added capability stuff.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=calf-ladspa
VERSION=${VERSION:-0.0.19kx}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

# 20151106 bkw: --enable-experimental only enables the fluidsynth
# module, which doesn't work as LADSPA (needs to be DSSI or LV2), so
# leave it disabled here.
EXPOPT=disable

# We'll disable what we can, and rm -rf what we don't need after install.
LADSPA_OPT="--with-ladspa-dir=/usr/lib${LIBDIRSUFFIX}/ladspa"
DSSI_OPT="--without-dssi"
LV2_OPT="--without-lv2"

set -e

SRCNAM=calf

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# There are no --without or --disable options for jack and fluidsynth,
# so patch the autoconf to skip them (they're not needed for the LADSPA
# plugins).
patch -p1 < $CWD/disable-jack-and-fluidsynth.diff

# gcc 7 is very picky about the argument types of std::min() and std::max().
# This patch replaces them with C-style MIN and MAX macros.
patch -p1 < $CWD/minmax.diff

autoreconf -if

# Note: The build ignores the provided -O2 in the flags (but the
# -march/-mtune -fPIC stuff is used). If you really want to force
# it to use -O2 (Slackware default), set FORCE_SLACK_CFLAGS=yes
# in the environment.
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
  sed -i -e 's/ -O3[^"]*//' configure
fi

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --${EXPOPT}-experimental \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --htmldir=/usr/doc/$PRGNAM-$VERSION \
  --enable-shared \
  --disable-static \
  $LADSPA_OPT \
  $DSSI_OPT \
  $LV2_OPT \
  --build=$ARCH-slackware-linux

make
make install DESTDIR=$PKG docdir=/usr/doc/$PRGNAM-$VERSION/html

# install-strip is supported, but doesn't work:
strip $PKG/usr/lib*/ladspa/*.so

# This build is only for the ladspa plugins, so none of this
# other stuff should be in the package:
rm -rf $PKG/usr/share $PKG/usr/bin $PKG/usr/man $PKG/usr/lib64/calf

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING* ChangeLog README TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE