summaryrefslogtreecommitdiffstats
path: root/audio/ardour/ardour.SlackBuild
blob: da8895a67c28c9f0f9715739c2043c52b85a8c27 (plain)
#!/bin/sh

# Slackware build script for ardour

# Copyright 2008-2014 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=ardour
VERSION=2.8.16
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "${LV2:-no}" = "no" ]; then
  lv2opt="LV2=0 LV2_UI=0"
else
  lv2opt="LV2=1 LV2_UI=1"
fi

if [ "${WIIMOTE:-no}" = "no" ]; then
  wiiopt="WIIMOTE=0"
else
  wiiopt="WIIMOTE=1"
fi

if [ "${VST:-no}" = "no" ]; then
  vstopt="VST=0"
else
  vstopt="VST=1"
fi

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
  TARGET="i386"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
  TARGET="i686"
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
  TARGET="x86_64"
  vstopt="VST=0"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
  TARGET="$ARCH"
  vstopt="VST=0"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# Make FREEDESKTOP work with DESTDIR
patch -d gtk2_ardour -p0 -i $CWD/SConscript.diff

# Omit -O3 from the CFLAGS
patch -p1 -i $CWD/SConstruct.diff

# Bugfixes from git
patch -p1 -i $CWD/tempoline_crash.patch
patch -p1 -i $CWD/lilv.patch
patch -p1 -i $CWD/boost_startup.patch

# Fix linking with boost
sed -i "s|lcwiid|lcwiid -lboost_system|" libs/surfaces/wiimote/SConscript

scons \
  PREFIX=/usr \
  LIBDIR=/usr/lib${LIBDIRSUFFIX} \
  DIST_TARGET="$TARGET" \
  ARCH="$(echo $SLKCFLAGS)" \
  FREEDESKTOP=1 \
  SYSLIBS=1 \
  $wiiopt \
  $lv2opt \
  $vstopt

scons \
  --implicit-deps-unchanged \
  PREFIX=/usr \
  LIBDIR=/usr/lib${LIBDIRSUFFIX} \
  DIST_TARGET="$TARGET" \
  ARCH="$(echo $SLKCFLAGS)" \
  FREEDESKTOP=1 \
  SYSLIBS=1 \
  $wiiopt \
  $lv2opt \
  $vstopt \
  DESTDIR=$PKG \
  install

if [ $vstopt = "VST=1" ]; then
  ln -s /usr/bin/ardourvst $PKG/usr/bin/ardour2
fi

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING PACKAGER_README README \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

# Let's not clobber config files
cd $PKG/etc/ardour2
  for i in * ; do
    mv $i $i.new
    echo "config etc/ardour2/$i.new" >> $PKG/install/doinst.sh
  done
cd -

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$TARGET-$BUILD$TAG.${PKGTYPE:-tgz}