summaryrefslogtreecommitdiffstats
path: root/academic/cap3/cap3.SlackBuild
blob: 65359adf4b46ae40a1fab9b50308491a622e8b75 (plain)
#!/bin/bash

# Slackware build script for cap3

# Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220405 bkw: Modified by SlackBuilds.org, BUILD=3: fix doc permissions.

# 20220318 bkw: Modified by SlackBuilds.org: fix 32-bit build when ARCH
# set to i586 or i686 in environment.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=cap3
VERSION=${VERSION:-20091029} # Use the last modification date as version
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

case "$ARCH" in
  x86_64) SRCARCH=".x86_64" ;;
  i?86)   SRCARCH=""        ;;
  *) echo "Unsupported ARCH '$ARCH'"; exit 1 ;;
esac

# Construct tarball name
TARNAME=${PRGNAM}.linux${SRCARCH}
DIRNAM=CAP3

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -fr $DIRNAM
tar xvf $CWD/$TARNAME.tar
cd $DIRNAM
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \+

install -s -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
install -s -D -m755 formcon $PKG/usr/bin/formcon

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
install -m0644 \
  aceform doc README \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
cat $CWD/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE