summaryrefslogtreecommitdiffstats
path: root/system/virtualbox
diff options
context:
space:
mode:
Diffstat (limited to 'system/virtualbox')
-rw-r--r--system/virtualbox/006-rdesktop-vrdp-keymap-path.patch4
-rw-r--r--system/virtualbox/10-virtualbox.rules5
-rw-r--r--system/virtualbox/LocalConfig.kmk11
-rw-r--r--system/virtualbox/vboxdrv.sh-setup.diff360
-rw-r--r--system/virtualbox/virtualbox-6.1.6-qt-5.15.patch92
-rw-r--r--system/virtualbox/virtualbox-gsoap.patch40
-rw-r--r--system/virtualbox/virtualbox.SlackBuild43
-rw-r--r--system/virtualbox/virtualbox.info18
8 files changed, 422 insertions, 151 deletions
diff --git a/system/virtualbox/006-rdesktop-vrdp-keymap-path.patch b/system/virtualbox/006-rdesktop-vrdp-keymap-path.patch
index 46c72c1ccf..217aa4970b 100644
--- a/system/virtualbox/006-rdesktop-vrdp-keymap-path.patch
+++ b/system/virtualbox/006-rdesktop-vrdp-keymap-path.patch
@@ -1,6 +1,6 @@
# 2015 © Sébastien Luttringer
---- a/src/VBox/RDP/client-1.8.3/Makefile.kmk 2013-02-19 23:12:20.207464901 +0100
-+++ b/src/VBox/RDP/client-1.8.3/Makefile.kmk 2014-01-04 04:17:26.700618600 +0100
+--- a/src/VBox/RDP/client-1.8.4/Makefile.kmk 2013-02-19 23:12:20.207464901 +0100
++++ b/src/VBox/RDP/client-1.8.4/Makefile.kmk 2014-01-04 04:17:26.700618600 +0100
@@ -41,7 +41,7 @@
EGD_SOCKET=\"/var/run/egd-pool\" WITH_RDPSND=1 HAVE_DIRENT_H=1 \
HAVE_ICONV=1 HAVE_SYS_STATVFS_H=1 \
diff --git a/system/virtualbox/10-virtualbox.rules b/system/virtualbox/10-virtualbox.rules
index cdddafb97c..db7ade9e0a 100644
--- a/system/virtualbox/10-virtualbox.rules
+++ b/system/virtualbox/10-virtualbox.rules
@@ -1,7 +1,8 @@
KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0660"
KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="vboxusers", MODE="0660"
-SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
-SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
+
+SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
+SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
diff --git a/system/virtualbox/LocalConfig.kmk b/system/virtualbox/LocalConfig.kmk
index 379c93fb45..8003032c10 100644
--- a/system/virtualbox/LocalConfig.kmk
+++ b/system/virtualbox/LocalConfig.kmk
@@ -5,6 +5,7 @@ DEFS += RTPATH_APP_PRIVATE=\"/usr/share/virtualbox\"
# don't build testcases to save time, they are not needed for the package
VBOX_WITH_TESTCASES :=
VBOX_WITH_TESTSUITE :=
+VBOX_WITH_VALIDATIONKIT :=
# don't build guest-additions, they will come in a separate build
VBOX_WITHOUT_ADDITIONS := 1
@@ -32,3 +33,13 @@ VBOX_JAVA_HOME := /usr/LIBDIR/java
# Do not build docs from source. Depends on texlive...
VBOX_WITHOUT_DOCS := 1
+
+# Use our CFLAGS
+VBOX_GCC_OPT := CXXFLAGS
+
+# Don't display update requests as we manage updates via packages
+VBOX_WITH_UPDATE_REQUEST :=
+
+# Build useful tools linked to testcases
+VBOX_WITH_VBOX_IMG := 1
+VBOX_WITH_VBOXIMGMOUNT := 1
diff --git a/system/virtualbox/vboxdrv.sh-setup.diff b/system/virtualbox/vboxdrv.sh-setup.diff
index 0adf8ec237..bb2be6fc89 100644
--- a/system/virtualbox/vboxdrv.sh-setup.diff
+++ b/system/virtualbox/vboxdrv.sh-setup.diff
@@ -1,93 +1,299 @@
---- VirtualBox-4.3.4.orig/src/VBox/Installer/linux/vboxdrv.sh.in 2013-11-29 20:24:07.000000000 +0100
-+++ VirtualBox-4.3.4/src/VBox/Installer/linux/vboxdrv.sh.in 2013-12-08 18:08:09.667571974 +0100
-@@ -44,17 +44,13 @@
+--- VirtualBox-6.1.4.orig/src/VBox/Installer/linux/vboxdrv.sh 2020-02-18 18:20:19.000000000 +0100
++++ VirtualBox-6.1.4/src/VBox/Installer/linux/vboxdrv.sh 2020-02-22 14:33:41.141337430 +0100
+@@ -61,23 +61,8 @@
+ export USERNAME
+ export USER=$USERNAME
- if [ -n "$INSTALL_DIR" ]; then
- VBOXMANAGE="$INSTALL_DIR/VBoxManage"
-- MODULE_SRC="$INSTALL_DIR/src/vboxhost"
- else
- VBOXMANAGE="/usr/lib/virtualbox/VBoxManage"
+-if test -n "${INSTALL_DIR}" && test -x "${INSTALL_DIR}/VirtualBox"; then
+- MODULE_SRC="${INSTALL_DIR}/src/vboxhost"
+-elif test -x /usr/lib/virtualbox/VirtualBox; then
+- INSTALL_DIR=/usr/lib/virtualbox
- MODULE_SRC="/usr/share/virtualbox/src/vboxhost"
- fi
--BUILDINTMP="$MODULE_SRC/build_in_tmp"
--DODKMS="$MODULE_SRC/do_dkms"
+-elif test -x "${SCRIPT_DIR}/VirtualBox"; then
+- # Executing from the build directory
+- INSTALL_DIR="${SCRIPT_DIR}"
+- MODULE_SRC="${INSTALL_DIR}/src"
+-else
+- # Silently exit if the package was uninstalled but not purged.
+- # Applies to Debian packages only (but shouldn't hurt elsewhere)
+- exit 0
+-fi
+ VIRTUALBOX="${INSTALL_DIR}/VirtualBox"
+ VBOXMANAGE="${INSTALL_DIR}/VBoxManage"
+-BUILDINTMP="${MODULE_SRC}/build_in_tmp"
+ if test -u "${VIRTUALBOX}"; then
+ GROUP=root
+ DEVICE_MODE=0600
+@@ -148,125 +133,6 @@
+ echo "${1}" >> "${LOG}"
+ }
+
+-module_build_log()
+-{
+- setup_log
+- echo "${1}" | egrep -v \
+- "^test -e include/generated/autoconf.h|^echo >&2|^/bin/false\)$" \
+- >> "${LOG}"
+-}
+-
+-## Output the vboxdrv part of our udev rule. This is redirected to the right file.
+-udev_write_vboxdrv() {
+- VBOXDRV_GRP="$1"
+- VBOXDRV_MODE="$2"
+-
+- echo "KERNEL==\"vboxdrv\", NAME=\"vboxdrv\", OWNER=\"root\", GROUP=\"$VBOXDRV_GRP\", MODE=\"$VBOXDRV_MODE\""
+- echo "KERNEL==\"vboxdrvu\", NAME=\"vboxdrvu\", OWNER=\"root\", GROUP=\"root\", MODE=\"0666\""
+- echo "KERNEL==\"vboxnetctl\", NAME=\"vboxnetctl\", OWNER=\"root\", GROUP=\"$VBOXDRV_GRP\", MODE=\"$VBOXDRV_MODE\""
+-}
+-
+-## Output the USB part of our udev rule. This is redirected to the right file.
+-udev_write_usb() {
+- INSTALLATION_DIR="$1"
+- USB_GROUP="$2"
+-
+- echo "SUBSYSTEM==\"usb_device\", ACTION==\"add\", RUN+=\"$INSTALLATION_DIR/VBoxCreateUSBNode.sh \$major \$minor \$attr{bDeviceClass}${USB_GROUP}\""
+- echo "SUBSYSTEM==\"usb\", ACTION==\"add\", ENV{DEVTYPE}==\"usb_device\", RUN+=\"$INSTALLATION_DIR/VBoxCreateUSBNode.sh \$major \$minor \$attr{bDeviceClass}${USB_GROUP}\""
+- echo "SUBSYSTEM==\"usb_device\", ACTION==\"remove\", RUN+=\"$INSTALLATION_DIR/VBoxCreateUSBNode.sh --remove \$major \$minor\""
+- echo "SUBSYSTEM==\"usb\", ACTION==\"remove\", ENV{DEVTYPE}==\"usb_device\", RUN+=\"$INSTALLATION_DIR/VBoxCreateUSBNode.sh --remove \$major \$minor\""
+-}
+-
+-## Generate our udev rule file. This takes a change in udev rule syntax in
+-## version 55 into account. It only creates rules for USB for udev versions
+-## recent enough to support USB device nodes.
+-generate_udev_rule() {
+- VBOXDRV_GRP="$1" # The group owning the vboxdrv device
+- VBOXDRV_MODE="$2" # The access mode for the vboxdrv device
+- INSTALLATION_DIR="$3" # The directory VirtualBox is installed in
+- USB_GROUP="$4" # The group that has permission to access USB devices
+- NO_INSTALL="$5" # Set this to "1" to remove but not re-install rules
+-
+- # Extra space!
+- case "$USB_GROUP" in ?*) USB_GROUP=" $USB_GROUP" ;; esac
+- case "$NO_INSTALL" in "1") return ;; esac
+- udev_write_vboxdrv "$VBOXDRV_GRP" "$VBOXDRV_MODE"
+- udev_write_usb "$INSTALLATION_DIR" "$USB_GROUP"
+-}
+-
+-## Install udev rule (disable with INSTALL_NO_UDEV=1 in
+-## /etc/default/virtualbox).
+-install_udev() {
+- VBOXDRV_GRP="$1" # The group owning the vboxdrv device
+- VBOXDRV_MODE="$2" # The access mode for the vboxdrv device
+- INSTALLATION_DIR="$3" # The directory VirtualBox is installed in
+- USB_GROUP="$4" # The group that has permission to access USB devices
+- NO_INSTALL="$5" # Set this to "1" to remove but not re-install rules
+-
+- if test -d /etc/udev/rules.d; then
+- generate_udev_rule "$VBOXDRV_GRP" "$VBOXDRV_MODE" "$INSTALLATION_DIR" \
+- "$USB_GROUP" "$NO_INSTALL"
+- fi
+- # Remove old udev description file
+- rm -f /etc/udev/rules.d/10-vboxdrv.rules 2> /dev/null
+-}
+-
+-## Create a usb device node for a given sysfs path to a USB device.
+-install_create_usb_node_for_sysfs() {
+- path="$1" # sysfs path for the device
+- usb_createnode="$2" # Path to the USB device node creation script
+- usb_group="$3" # The group to give ownership of the node to
+- if test -r "${path}/dev"; then
+- dev="`cat "${path}/dev" 2> /dev/null`"
+- major="`expr "$dev" : '\(.*\):' 2> /dev/null`"
+- minor="`expr "$dev" : '.*:\(.*\)' 2> /dev/null`"
+- class="`cat ${path}/bDeviceClass 2> /dev/null`"
+- sh "${usb_createnode}" "$major" "$minor" "$class" \
+- "${usb_group}" 2>/dev/null
+- fi
+-}
+-
+-udev_rule_file=/etc/udev/rules.d/60-vboxdrv.rules
+-sysfs_usb_devices="/sys/bus/usb/devices/*"
+-
+-## Install udev rules and create device nodes for usb access
+-setup_usb() {
+- VBOXDRV_GRP="$1" # The group that should own /dev/vboxdrv
+- VBOXDRV_MODE="$2" # The mode to be used for /dev/vboxdrv
+- INSTALLATION_DIR="$3" # The directory VirtualBox is installed in
+- USB_GROUP="$4" # The group that should own the /dev/vboxusb device
+- # nodes unless INSTALL_NO_GROUP=1 in
+- # /etc/default/virtualbox. Optional.
+- usb_createnode="$INSTALLATION_DIR/VBoxCreateUSBNode.sh"
+- # install udev rule (disable with INSTALL_NO_UDEV=1 in
+- # /etc/default/virtualbox)
+- if [ "$INSTALL_NO_GROUP" != "1" ]; then
+- usb_group=$USB_GROUP
+- vboxdrv_group=$VBOXDRV_GRP
+- else
+- usb_group=root
+- vboxdrv_group=root
+- fi
+- install_udev "${vboxdrv_group}" "$VBOXDRV_MODE" \
+- "$INSTALLATION_DIR" "${usb_group}" \
+- "$INSTALL_NO_UDEV" > ${udev_rule_file}
+- # Build our device tree
+- for i in ${sysfs_usb_devices}; do # This line intentionally without quotes.
+- install_create_usb_node_for_sysfs "$i" "${usb_createnode}" \
+- "${usb_group}"
+- done
+-}
+-
+-cleanup_usb()
+-{
+- # Remove udev description file
+- rm -f /etc/udev/rules.d/60-vboxdrv.rules
+- rm -f /etc/udev/rules.d/10-vboxdrv.rules
+-
+- # Remove our USB device tree
+- rm -rf /dev/vboxusb
+-}
+-
+ start()
+ {
+ begin_msg "Starting VirtualBox services" console
+@@ -287,10 +153,7 @@
+ failure "Cannot remove $DEVICE"
+ fi
+ if ! $MODPROBE vboxdrv > /dev/null 2>&1; then
+- setup
+- if ! $MODPROBE vboxdrv > /dev/null 2>&1; then
+- failure "modprobe vboxdrv failed. Please use 'dmesg' to find out why"
+- fi
++ failure "modprobe vboxdrv failed. Please use 'dmesg' to find out why"
+ fi
+ sleep .2
+ fi
+@@ -337,8 +200,6 @@
+ mkdir -p -m 0750 /dev/vboxusb 2>/dev/null
+ chown root:vboxusers /dev/vboxusb 2>/dev/null
+ fi
+- # Remove any kernel modules left over from previously installed kernels.
+- cleanup only_old
+ succ_msg "VirtualBox services started"
+ }
- # silently exit if the package was uninstalled but not purged,
- # applies to Debian packages only (but shouldn't hurt elsewhere)
--[ ! -f /etc/debian_release -o -x $VBOXMANAGE -a -x $BUILDINTMP ] || exit 0
-+[ ! -f /etc/debian_release -o -x $VBOXMANAGE ] || exit 0
+@@ -419,102 +280,10 @@
+ fi
+ }
- if [ -n "$NOLSB" ]; then
- if [ -f /etc/redhat-release ]; then
-@@ -295,70 +291,7 @@
+-cleanup()
+-{
+- # If this is set, only remove kernel modules for no longer installed
+- # kernels. Note that only generated kernel modules should be placed
+- # in /lib/modules/*/misc. Anything that we should not remove automatically
+- # should go elsewhere.
+- only_old="${1}"
+- for i in /lib/modules/*; do
+- # Check whether we are only cleaning up for uninstalled kernels.
+- test -n "${only_old}" && test -e "${i}/kernel/drivers" && continue
+- # We could just do "rm -f", but we only want to try deleting folders if
+- # we are sure they were ours, i.e. they had our modules in beforehand.
+- if test -e "${i}/misc/vboxdrv.ko" \
+- || test -e "${i}/misc/vboxnetadp.ko" \
+- || test -e "${i}/misc/vboxnetflt.ko" \
+- || test -e "${i}/misc/vboxpci.ko"; then
+- rm -f "${i}/misc/vboxdrv.ko" "${i}/misc/vboxnetadp.ko" \
+- "${i}/misc/vboxnetflt.ko" "${i}/misc/vboxpci.ko"
+- version=`expr "${i}" : "/lib/modules/\(.*\)"`
+- depmod -a "${version}"
+- sync
+- fi
+- # Remove the kernel version folder if it was empty except for us.
+- test "`echo ${i}/misc/* ${i}/misc/.?* ${i}/* ${i}/.?*`" \
+- = "${i}/misc/* ${i}/misc/.. ${i}/misc ${i}/.." &&
+- rmdir "${i}/misc" "${i}" # We used to leave empty folders.
+- done
+-}
+-
# setup_script
setup()
{
-- stop
-- DKMS=`which dkms 2>/dev/null`
-- if [ -n "$DKMS" ]; then
-- begin_msg "Uninstalling old VirtualBox DKMS kernel modules"
-- $DODKMS uninstall vboxhost vboxdrv vboxnetflt vboxnetadp > $LOG
-- succ_msg
+- begin_msg "Building VirtualBox kernel modules" console
+- log "Building the main VirtualBox module."
+- if ! myerr=`$BUILDINTMP \
+- --save-module-symvers /tmp/vboxdrv-Module.symvers \
+- --module-source "$MODULE_SRC/vboxdrv" \
+- --no-print-directory install 2>&1`; then
+- "${INSTALL_DIR}/check_module_dependencies.sh" || exit 1
+- log "Error building the module:"
+- module_build_log "$myerr"
+- failure "Look at $LOG to find out what went wrong"
- fi
-- if find /lib/modules/`uname -r` -name "vboxpci\.*" 2>/dev/null|grep -q vboxpci; then
-- begin_msg "Removing old VirtualBox pci kernel module"
-- find /lib/modules/`uname -r` -name "vboxpci\.*" 2>/dev/null|xargs rm -f 2>/dev/null
-- succ_msg
-- fi
-- if find /lib/modules/`uname -r` -name "vboxnetadp\.*" 2>/dev/null|grep -q vboxnetadp; then
-- begin_msg "Removing old VirtualBox netadp kernel module"
-- find /lib/modules/`uname -r` -name "vboxnetadp\.*" 2>/dev/null|xargs rm -f 2>/dev/null
-- succ_msg
-- fi
-- if find /lib/modules/`uname -r` -name "vboxnetflt\.*" 2>/dev/null|grep -q vboxnetflt; then
-- begin_msg "Removing old VirtualBox netflt kernel module"
-- find /lib/modules/`uname -r` -name "vboxnetflt\.*" 2>/dev/null|xargs rm -f 2>/dev/null
-- succ_msg
-- fi
-- if find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|grep -q vboxdrv; then
-- begin_msg "Removing old VirtualBox kernel module"
-- find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|xargs rm -f 2>/dev/null
-- succ_msg
+- log "Building the net filter module."
+- if ! myerr=`$BUILDINTMP \
+- --use-module-symvers /tmp/vboxdrv-Module.symvers \
+- --module-source "$MODULE_SRC/vboxnetflt" \
+- --no-print-directory install 2>&1`; then
+- log "Error building the module:"
+- module_build_log "$myerr"
+- failure "Look at $LOG to find out what went wrong"
- fi
-- if [ -n "$DKMS" ]; then
-- begin_msg "Trying to register the VirtualBox kernel modules using DKMS"
-- if ! $DODKMS install vboxhost $VERSION >> $LOG; then
-- fail_msg "Failed, trying without DKMS"
-- DKMS=""
-- fi
+- log "Building the net adaptor module."
+- if ! myerr=`$BUILDINTMP \
+- --use-module-symvers /tmp/vboxdrv-Module.symvers \
+- --module-source "$MODULE_SRC/vboxnetadp" \
+- --no-print-directory install 2>&1`; then
+- log "Error building the module:"
+- module_build_log "$myerr"
+- failure "Look at $LOG to find out what went wrong"
- fi
-- if [ -z "$DKMS" ]; then
-- begin_msg "Recompiling VirtualBox kernel modules"
-- if ! $BUILDINTMP \
-- --save-module-symvers /tmp/vboxdrv-Module.symvers \
-- --module-source "$MODULE_SRC/vboxdrv" \
-- --no-print-directory install >> $LOG 2>&1; then
-- failure "Look at $LOG to find out what went wrong"
-- fi
-- if ! $BUILDINTMP \
-- --use-module-symvers /tmp/vboxdrv-Module.symvers \
-- --module-source "$MODULE_SRC/vboxnetflt" \
-- --no-print-directory install >> $LOG 2>&1; then
-- failure "Look at $LOG to find out what went wrong"
-- fi
-- if ! $BUILDINTMP \
-- --use-module-symvers /tmp/vboxdrv-Module.symvers \
-- --module-source "$MODULE_SRC/vboxnetadp" \
-- --no-print-directory install >> $LOG 2>&1; then
-- failure "Look at $LOG to find out what went wrong"
-- fi
-- if ! $BUILDINTMP \
-- --use-module-symvers /tmp/vboxdrv-Module.symvers \
-- --module-source "$MODULE_SRC/vboxpci" \
-- --no-print-directory install >> $LOG 2>&1; then
-- failure "Look at $LOG to find out what went wrong"
-- fi
+- if test -e "$MODULE_SRC/vboxpci"; then
+- log "Building the PCI pass-through module."
+- if ! myerr=`$BUILDINTMP \
+- --use-module-symvers /tmp/vboxdrv-Module.symvers \
+- --module-source "$MODULE_SRC/vboxpci" \
+- --no-print-directory install 2>&1`; then
+- log "Error building the module:"
+- module_build_log "$myerr"
+- failure "Look at $LOG to find out what went wrong"
+- fi
- fi
- rm -f /etc/vbox/module_not_compiled
-- succ_msg
-- start
+- depmod -a
+- sync
+- succ_msg "VirtualBox kernel modules built"
+- # Secure boot on Ubuntu and Debian.
+- if test -n "$HAVE_SEC_BOOT" &&
+- type update-secureboot-policy >/dev/null 2>&1; then
+- SHIM_NOTRIGGER=y update-secureboot-policy --new-key
+- fi
+- if test -f "$DEB_PUB_KEY" && test -f "$DEB_PRIV_KEY"; then
+- HAVE_DEB_KEY=true
+- for i in $MODULE_LIST; do
+- kmodsign sha512 /var/lib/shim-signed/mok/MOK.priv \
+- /var/lib/shim-signed/mok/MOK.der \
+- /lib/modules/"$KERN_VER"/misc/"$i".ko
+- done
+- # update-secureboot-policy "expects" DKMS modules.
+- # Work around this and talk to the authors as soon
+- # as possible to fix it.
+- mkdir -p /var/lib/dkms/vbox-temp
+- update-secureboot-policy --enroll-key 2>/dev/null ||
+- begin_msg "Failed to enroll secure boot key." console
+- rmdir -p /var/lib/dkms/vbox-temp 2>/dev/null
+- fi
+ echo "Not implemented! Please use the virtualbox-kernel.SlackBuild available at SlackBuilds.org instead."
}
dmnstatus()
+@@ -564,20 +333,7 @@
+ stop && start
+ ;;
+ setup)
+- test -n "${2}" && export KERN_VER="${2}"
+- # Create udev rule and USB device nodes.
+- ## todo Wouldn't it make more sense to install the rule to /lib/udev? This
+- ## is not a user-created configuration file after all.
+- ## todo Do we need a udev rule to create /dev/vboxdrv[u] at all? We have
+- ## working fall-back code here anyway, and the "right" code is more complex
+- ## than the fall-back. Unnecessary duplication?
+- stop && cleanup
+- setup_usb "$GROUP" "$DEVICE_MODE" "$INSTALL_DIR"
+- start
+- ;;
+-cleanup)
+- stop && cleanup
+- cleanup_usb
++ setup
+ ;;
+ force-reload)
+ stop
diff --git a/system/virtualbox/virtualbox-6.1.6-qt-5.15.patch b/system/virtualbox/virtualbox-6.1.6-qt-5.15.patch
new file mode 100644
index 0000000000..36f525593e
--- /dev/null
+++ b/system/virtualbox/virtualbox-6.1.6-qt-5.15.patch
@@ -0,0 +1,92 @@
+--- a/src/VBox/Frontends/VirtualBox/src/globals/UIImageTools.cpp 2020-05-29 23:51:41.504432532 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/globals/UIImageTools.cpp 2020-05-29 23:49:26.943858460 +0300
+@@ -17,6 +17,8 @@
+
+ /* Qt includes: */
+ #include <QPainter>
++#include <QPainterPath>
++#include <QPainterPathStroker>
+
+ /* GUI include */
+ #include "UIImageTools.h"
+
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIPopupBox.h 2020-05-30 00:09:50.369275092 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIPopupBox.h 2020-05-30 00:01:14.152354690 +0300
+@@ -24,6 +24,7 @@
+ /* Qt includes: */
+ #include <QIcon>
+ #include <QWidget>
++#include <QPainterPath>
+
+ /* GUI includes: */
+ #include "UILibraryDefs.h"
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIMenuToolBar.cpp 2020-05-30 00:39:54.773447224 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIMenuToolBar.cpp 2020-05-30 00:41:36.274371761 +0300
+@@ -21,6 +21,7 @@
+ #include <QPainter>
+ #include <QStyle>
+ #include <QToolButton>
++#include <QPainterPath>
+
+ /* GUI includes: */
+ #include "UIMenuToolBar.h"
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UITabBar.cpp 2020-05-30 00:39:47.613523134 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UITabBar.cpp 2020-05-30 00:41:29.655441857 +0300
+@@ -29,6 +29,7 @@
+ #include <QMouseEvent>
+ #include <QStyleOption>
+ #include <QPainter>
++#include <QPainterPath>
+ #ifdef VBOX_WS_MAC
+ # include <QStackedLayout>
+ #endif
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIFilmContainer.cpp 2020-05-30 00:40:01.624374596 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIFilmContainer.cpp 2020-05-30 00:41:40.654325376 +0300
+@@ -23,6 +23,7 @@
+ #include <QScrollBar>
+ #include <QStyle>
+ #include <QVBoxLayout>
++#include <QPainterPath>
+
+ /* GUI includes: */
+ #include "UIFilmContainer.h"
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIPopupBox.cpp 2020-05-30 00:40:08.844298062 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIPopupBox.cpp 2020-05-30 00:41:44.594283652 +0300
+@@ -22,6 +22,7 @@
+ #include <QPaintEvent>
+ #include <QStyle>
+ #include <QVBoxLayout>
++#include <QPainterPath>
+
+ /* GUI includes: */
+ #include "UIPopupBox.h"
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp 2020-05-30 00:40:16.064221530 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp 2020-05-30 00:41:52.014205079 +0300
+@@ -27,6 +27,7 @@
+ #include <QToolButton>
+ #include <QVBoxLayout>
+ #include <QWindow>
++#include <QPainterPath>
+ #ifdef VBOX_WS_X11
+ # include <QWindowStateChangeEvent>
+ #endif
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/graphics/UIGraphicsScrollBar.cpp 2020-05-30 00:40:22.314155286 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/graphics/UIGraphicsScrollBar.cpp 2020-05-30 00:41:56.544157111 +0300
+@@ -28,6 +28,7 @@
+ #include <QStyleOptionGraphicsItem>
+ #include <QTimer>
+ #include <QTimerEvent>
++#include <QPainterPath>
+
+ /* GUI includes: */
+ #include "UIGraphicsButton.h"
+--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIPopupPane.cpp 2020-05-30 00:40:34.375027462 +0300
++++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIPopupPane.cpp 2020-05-30 00:42:01.244107347 +0300
+@@ -18,6 +18,7 @@
+ /* Qt includes: */
+ #include <QPainter>
+ #include <QTextEdit>
++#include <QPainterPath>
+
+ /* GUI includes: */
+ #include "UIPopupPane.h"
diff --git a/system/virtualbox/virtualbox-gsoap.patch b/system/virtualbox/virtualbox-gsoap.patch
deleted file mode 100644
index a8ba6f549c..0000000000
--- a/system/virtualbox/virtualbox-gsoap.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -u -r VirtualBox-5.0.10.orig/src/VBox/Main/webservice/Makefile.kmk VirtualBox-5.0.10/src/VBox/Main/webservice/Makefile.kmk
---- VirtualBox-5.0.10.orig/src/VBox/Main/webservice/Makefile.kmk 2015-11-10 18:06:29.000000000 +0100
-+++ VirtualBox-5.0.10/src/VBox/Main/webservice/Makefile.kmk 2015-11-22 09:58:21.669118291 +0100
-@@ -159,7 +159,6 @@
- RECOMPILE_ON_MAKEFILE_CURRENT := $(MAKEFILE_CURRENT)
-
- PATH_TARGET_SOAPDEMOXML := $(VBOXWEB_OUT_DIR)/demo_soapxml
--PATH_TARGET_SOAPDEMOHEADERS := $(VBOXWEB_OUT_DIR)/demo_headers
- PATH_TARGET_SOAPDEMONSMAPS := $(VBOXWEB_OUT_DIR)/demo_namespacemaps
- PATH_TARGET_WEBTEST := $(VBOXWEB_OUT_DIR)/webtest
-
-@@ -515,8 +514,6 @@
- $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts \
- $(wildcard $(PATH_TARGET_SOAPDEMOXML)/*) \
- $(PATH_TARGET_SOAPDEMOXML)/dummy_file \
-- $(wildcard $(PATH_TARGET_SOAPDEMOHEADERS)/*) \
-- $(PATH_TARGET_SOAPDEMOHEADERS)/dummy_file \
- $(wildcard $(PATH_TARGET_SOAPDEMONSMAPS)/*) \
- $(PATH_TARGET_SOAPDEMONSMAPS)/dummy_file
-
-@@ -695,17 +692,14 @@
- # any more. Ignoring the exit code is the simple solution, accepting the error.
- $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts: $(VBOXWEB_OUT_DIR)/gsoap_generate_all_ts | $$(dir $$@)
- $(RM) -f $@
-- $(MKDIR) -p $(PATH_TARGET_SOAPDEMOXML) $(PATH_TARGET_SOAPDEMOHEADERS) $(PATH_TARGET_SOAPDEMONSMAPS)
-+ $(MKDIR) -p $(PATH_TARGET_SOAPDEMOXML) $(PATH_TARGET_SOAPDEMONSMAPS)
- ifdef VBOX_GSOAP_VERBOSE
- $(MV_EXT) -f -- $(VBOXWEB_OUT_DIR)/*.req.xml $(VBOXWEB_OUT_DIR)/*.res.xml $(PATH_TARGET_SOAPDEMOXML)/
- endif
-- -$(MV_EXT) -f -- $(VBOXWEB_OUT_DIR)/soapvbox*.h $(PATH_TARGET_SOAPDEMOHEADERS)/
- $(MV_EXT) -f -- $(VBOXWEB_OUT_DIR)/vboxBinding.nsmap $(PATH_TARGET_SOAPDEMONSMAPS)/
- $(APPEND) $@ done
-
--$(PATH_TARGET_SOAPDEMONSMAPS) \
--$(PATH_TARGET_SOAPDEMOHEADERS)/soapvboxBindingProxy.h \
--$(PATH_TARGET_SOAPDEMOHEADERS)/soapvboxBindingObject.h: $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts
-+$(PATH_TARGET_SOAPDEMONSMAPS): $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts
-
- # soapcpp2 -2: generate SOAP 1.2 calls
- # soapcpp2 -S: server-side code only
diff --git a/system/virtualbox/virtualbox.SlackBuild b/system/virtualbox/virtualbox.SlackBuild
index 1048ea0771..d1d577363c 100644
--- a/system/virtualbox/virtualbox.SlackBuild
+++ b/system/virtualbox/virtualbox.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for virtualbox-ose
-# Copyright 2008-2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2020 Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2008 Mauro Giachero <mauro.giachero@gmail.com>
# All rights reserved.
#
@@ -25,7 +25,7 @@
PRGNAM=virtualbox
SRCNAM=VirtualBox
-VERSION=${VERSION:-5.0.40}
+VERSION=${VERSION:-6.1.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,12 +62,14 @@ else
harden="--disable-hardening"
fi
-# Support for the qt4-frontend
+# Support for the Qt & SDL frontends
if [ "${HEADLESS:-no}" = "no" ]; then
- guiapp="VirtualBox VBoxSDL"
+ guiapp="VirtualBox VirtualBoxVM VBoxSDL"
+ suidgui="VirtualBoxVM VBoxSDL"
else
gui+=" --build-headless"
guiapp=""
+ suidgui=""
fi
# Enable building of java bindings
@@ -128,21 +130,22 @@ find -L . \
GROUP="vboxusers"
MODE="755"
+# Fix building against qt-15.x, patch from gentoo
+patch -p1 -i $CWD/virtualbox-6.1.6-qt-5.15.patch
+
# We don't want an init-script building kernel modules.
# Use virtualbox-kernel.SlackBuild for this.
patch -d src/VBox/Installer/linux -i $CWD/vboxdrv.sh-setup.diff
-# Fix building against newer versions of gsoap
-patch -p1 -i $CWD/virtualbox-gsoap.patch
-
# Fix wrong path to rdesktop-vrdp-keymaps
patch -p1 -i $CWD/006-rdesktop-vrdp-keymap-path.patch
# Remove gcc version check
sed -i 's/^check_gcc$/#check_gcc/' ./configure
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+# Use our CFLAGS
+sed -i "s|CXX_FLAGS=\"\"|CXX_FLAGS=\"$SLKCFLAGS -std=c++11\"|" ./configure
+
./configure \
--disable-kmods \
--enable-vde \
@@ -158,20 +161,16 @@ CXXFLAGS="$SLKCFLAGS" \
cp $CWD/LocalConfig.kmk .
sed -i "s|LIBDIR|lib$LIBDIRSUFFIX|" ./LocalConfig.kmk
+sed -i "s|CXXFLAGS|$SLKCFLAGS -std=c++11|" ./LocalConfig.kmk
kmk -j ${JOBS} LOCALCFG=./LocalConfig.kmk
-# build VBoxFUSE
-cd src/VBox/ImageMounter/VBoxFUSE
- kmk -j ${JOBS}
-cd -
-
mkdir -p $PKG/usr/{lib$LIBDIRSUFFIX,share,include}/virtualbox \
$PKG/usr/{bin,src} \
$PKG/usr/share/{pixmaps,mime/packages} \
$PKG/etc/{default,rc.d,vbox}
-for i in vboxdrv.sh.in vboxballoonctrl-service.sh vboxautostart-service.sh; do
+for i in vboxdrv.sh vboxballoonctrl-service.sh vboxautostart-service.sh; do
SCRIPT=$(echo $i | cut -d "." -f 1)
cp -f src/VBox/Installer/linux/$i $PKG/etc/rc.d/rc.$SCRIPT.new
sed -i "s/%PACKAGE%/virtualbox/g" $PKG/etc/rc.d/rc.$SCRIPT.new
@@ -218,17 +217,15 @@ cd out/linux.$BUILDDIR/release/bin/
install -m $MODE -g $GROUP VBoxSysInfo.sh $PKG/usr/share/virtualbox/
install -m $MODE -g $GROUP VBoxCreateUSBNode.sh $PKG/usr/share/virtualbox/
install -m $MODE -g $GROUP VBoxTunctl $PKG/usr/bin/
- install -m $MODE -g $GROUP VBoxFUSE $PKG/usr/bin/
- rm -f VBoxSysInfo.sh VBoxCreateUSBNode.sh VBoxTunctl VBoxFUSE
+ rm -f VBoxSysInfo.sh VBoxCreateUSBNode.sh VBoxTunctl
mv * $PKG/usr/lib$LIBDIRSUFFIX/virtualbox/
chown -R root:$GROUP $PKG/usr/lib$LIBDIRSUFFIX/virtualbox/
chmod -R $MODE $PKG/usr/lib$LIBDIRSUFFIX/virtualbox/
mv $PKG/usr/lib$LIBDIRSUFFIX/virtualbox/VBox.sh $PKG/usr/lib$LIBDIRSUFFIX/virtualbox/VBox
cd $TMP/$SRCNAM-${VERSION}
-for i in VBoxManage vboxmanage VBoxHeadless \
- vboxheadless VBoxVRDP VBoxBalloonCtrl vboxballoonctrl \
- VBoxAutostart vboxautostart $guiapp $vboxwebsrv; do
+for i in VBoxManage VBoxHeadless VBoxVRDP VBoxBalloonCtrl VBoxBugReport \
+ VBoxAutostart $guiapp $vboxwebsrv; do
ln -s /usr/lib$LIBDIRSUFFIX/virtualbox/VBox $PKG/usr/bin/$i
done
@@ -238,6 +235,9 @@ if [ "${HEADLESS:-no}" = "no" ]; then
done
fi
+ln -s /usr/lib$LIBDIRSUFFIX/virtualbox/vbox-img $PKG/usr/bin/
+ln -s /usr/lib$LIBDIRSUFFIX/virtualbox/vboximg-mount $PKG/usr/bin/
+
if [ "$vboxwebsrv" = "vboxwebsrv" ]; then
mkdir -p $PKG/var/{lib,log}/vboxweb
chown vboxweb:vboxusers $PKG/var/{lib,log}/vboxweb
@@ -249,7 +249,7 @@ if [ "$vboxwebsrv" = "vboxwebsrv" ]; then
fi
if [ "$harden" = "--enable-hardening" ]; then
- for i in VBoxHeadless $guiapp VBoxNetDHCP VBoxNetAdpCtl; do
+ for i in VBoxHeadless $suidgui VBoxNetDHCP VBoxNetAdpCtl VBoxNetNAT; do
chmod 4711 $PKG/usr/lib$LIBDIRSUFFIX/virtualbox/$i
done
fi
@@ -257,6 +257,7 @@ fi
# install headers. Needed by some third party tools
cp -rf include/* $PKG/usr/include/virtualbox/
rm -f $PKG/usr/include/virtualbox/Makefile.kmk
+find $PKG/usr/include/virtualbox -name "Makefile.kup" -print0 | xargs -0 rm -f
cp -f $CWD/VBoxGuestAdditions_$VERSION.iso \
$PKG/usr/share/virtualbox/VBoxGuestAdditions.iso
diff --git a/system/virtualbox/virtualbox.info b/system/virtualbox/virtualbox.info
index 11fef8a32a..118c4f6a77 100644
--- a/system/virtualbox/virtualbox.info
+++ b/system/virtualbox/virtualbox.info
@@ -1,14 +1,14 @@
PRGNAM="virtualbox"
-VERSION="5.0.40"
+VERSION="6.1.10"
HOMEPAGE="https://www.virtualbox.org"
-DOWNLOAD="http://download.virtualbox.org/virtualbox/5.0.40/VirtualBox-5.0.40.tar.bz2 \
- http://download.virtualbox.org/virtualbox/5.0.40/VBoxGuestAdditions_5.0.40.iso \
- http://download.virtualbox.org/virtualbox/5.0.40/UserManual.pdf \
- http://download.virtualbox.org/virtualbox/5.0.40/SDKRef.pdf"
-MD5SUM="53b259e48a137b0185c169590e2dcb77 \
- 71afc65e09d1d4d02020f0403ac47622 \
- bdc4bf38dd3ed786385044841a4af147 \
- 684ac3f7d17532cd8396ea83ba1d57ea"
+DOWNLOAD="http://download.virtualbox.org/virtualbox/6.1.10/VirtualBox-6.1.10.tar.bz2 \
+ http://download.virtualbox.org/virtualbox/6.1.10/VBoxGuestAdditions_6.1.10.iso \
+ http://download.virtualbox.org/virtualbox/6.1.10/UserManual.pdf \
+ http://download.virtualbox.org/virtualbox/6.1.10/SDKRef.pdf"
+MD5SUM="b690ab7f2b6c7f9e46eabc101df021ed \
+ abbfda1a505eedbd2bea255fb60bffe6 \
+ 0063b494e26d20f0ae083edb02ea1937 \
+ 71346aeeebbc006e6a4a94b9008ae209"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="acpica virtualbox-kernel"