summaryrefslogtreecommitdiffstats
path: root/system/sunflower
diff options
context:
space:
mode:
Diffstat (limited to 'system/sunflower')
-rw-r--r--system/sunflower/README2
-rw-r--r--system/sunflower/doinst.sh9
-rw-r--r--system/sunflower/slack-desc19
-rw-r--r--system/sunflower/sunflower.SlackBuild108
-rw-r--r--system/sunflower/sunflower.info10
5 files changed, 148 insertions, 0 deletions
diff --git a/system/sunflower/README b/system/sunflower/README
new file mode 100644
index 0000000000..8c66b0e56f
--- /dev/null
+++ b/system/sunflower/README
@@ -0,0 +1,2 @@
+Sunflower is a small and highly customizable twin-panel file manager
+with support for plugins. It contains a built-in terminal.
diff --git a/system/sunflower/doinst.sh b/system/sunflower/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/system/sunflower/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/sunflower/slack-desc b/system/sunflower/slack-desc
new file mode 100644
index 0000000000..633b0afd27
--- /dev/null
+++ b/system/sunflower/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sunflower: sunflower (Twin-panel file manager)
+sunflower:
+sunflower: Sunflower is a small and highly customizable twin-panel file manager
+sunflower: with support for plugins.
+sunflower:
+sunflower:
+sunflower:
+sunflower:
+sunflower:
+sunflower:
+sunflower:
diff --git a/system/sunflower/sunflower.SlackBuild b/system/sunflower/sunflower.SlackBuild
new file mode 100644
index 0000000000..3368022b3b
--- /dev/null
+++ b/system/sunflower/sunflower.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/bash
+
+# Slackware build script for sunflower
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20220312 bkw: Modified by SlackBuilds.org: VERSION must be constant,
+# and match VERSION in the .info file. Also, do not install useless
+# INSTALL in documentation directory.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=sunflower
+VERSION=${VERSION:-0.5_63}
+SRCVER="$( echo $VERSION | tr _ - )"
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf Sunflower
+tar xvf $CWD/$PRGNAM-$SRCVER.tgz
+cd Sunflower
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
+
+# Detect Python 3 version
+# Code taken from FabioLolix, at Arch Linux AUR:
+# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=sunflower
+PYVER=$(python3 -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
+
+# Copy icons and translations
+install -Dm644 images/sunflower.svg "$PKG/usr/lib/python${PYVER}/site-packages/images/sunflower.svg"
+install -Dm644 images/sunflower.png "$PKG/usr/share/pixmaps/sunflower.png"
+cp -r translations "$PKG/usr/share/locale/"
+rmdir $PKG/usr/share/sunflower/translations
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp AUTHORS CHANGES COPYING LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/sunflower/sunflower.info b/system/sunflower/sunflower.info
new file mode 100644
index 0000000000..7cfdb82c73
--- /dev/null
+++ b/system/sunflower/sunflower.info
@@ -0,0 +1,10 @@
+PRGNAM="sunflower"
+VERSION="0.5_63"
+HOMEPAGE="https://sunflower-fm.org"
+DOWNLOAD="https://sunflower-fm.org/pub/sunflower-0.5-63.tgz"
+MD5SUM="33c0bba1ccaf256838f5be12ddad5e7f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="orphaned - no maintainer"
+EMAIL="nobody@nowhere"