summaryrefslogtreecommitdiffstats
path: root/system/slim/CMakeLists.txt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/slim/CMakeLists.txt.patch')
-rw-r--r--system/slim/CMakeLists.txt.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/slim/CMakeLists.txt.patch b/system/slim/CMakeLists.txt.patch
new file mode 100644
index 0000000000..9a29e6c2d7
--- /dev/null
+++ b/system/slim/CMakeLists.txt.patch
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2014-08-08 07:24:01.864876514 -0700
++++ CMakeLists.txt 2014-08-08 07:24:51.980873088 -0700
+@@ -221,7 +221,10 @@
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++## we have to comment this out or else
++## build will fail on slackware as pam
++## is required for slimlock
++#install(TARGETS slimlock RUNTIME DESTINATION bin)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES