summaryrefslogtreecommitdiffstats
path: root/system/kitty
diff options
context:
space:
mode:
Diffstat (limited to 'system/kitty')
-rw-r--r--system/kitty/README12
-rw-r--r--system/kitty/doinst.sh9
-rw-r--r--system/kitty/kitty.SlackBuild105
-rw-r--r--system/kitty/kitty.info10
-rw-r--r--system/kitty/slack-desc19
5 files changed, 155 insertions, 0 deletions
diff --git a/system/kitty/README b/system/kitty/README
new file mode 100644
index 0000000000..b038ff262c
--- /dev/null
+++ b/system/kitty/README
@@ -0,0 +1,12 @@
+kitty (fast, featureful, GPU-based terminal emulator)
+
+kitty is a terminal emulator for X11 and Wayland [1], which offloads
+the rendering to the GPU [2] and supports modern terminal features. It
+also supports tiling multiple terminal windows without using an extra
+program like screen or tmux.
+
+[1] For Wayland support, it may be necessary to add the following
+ line to ~/.config/kitty/kitty.conf:
+ linux_display_server wayland
+
+[2] Requires hardware-accelerated OpenGL support.
diff --git a/system/kitty/doinst.sh b/system/kitty/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/system/kitty/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/kitty/kitty.SlackBuild b/system/kitty/kitty.SlackBuild
new file mode 100644
index 0000000000..81d907d472
--- /dev/null
+++ b/system/kitty/kitty.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/bash
+
+# Slackware build script for kitty
+
+# Written by B. Watson (email removed)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20230720 bkw: hand over maintenance to Eugen Wissner.
+# 20221228 bkw: update for v0.26.5, fix sbopkglint gripes.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=kitty
+VERSION=${VERSION:-0.34.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# Note to self: don't use the Makefile, it just runs setup.py but
+# doesn't give us a way to pass options to it.
+
+# sed surgery: setup.py allows overriding the compiler flags, but
+# puts a -O3 *after* whatever we set them to. All our SLKCFLAGS
+# choices have -O2.
+
+sed -i 's,-O3,-O2,g' setup.py
+
+# The -Wl,-s makes the linker strip the binaries.
+# --ignore-compiler-warnings is needed to turn off -Werror.
+
+OVERRIDE_CPPFLAGS="$SLKCFLAGS -Wl,-s" \
+OVERRIDE_CFLAGS="$SLKCFLAGS -Wl,-s" \
+ python3 setup.py \
+ --libdir-name lib$LIBDIRSUFFIX \
+ --verbose linux-package \
+ --ignore-compiler-warnings
+
+mkdir -p $PKG/usr/bin $PKG/usr/share $PKG/usr/lib$LIBDIRSUFFIX
+cp -a linux-package/bin/* $PKG/usr/bin
+cp -a linux-package/share/* $PKG/usr/share
+cp -a linux-package/lib*/* $PKG/usr/lib$LIBDIRSUFFIX
+strip $PKG/usr/bin/$PRGNAM
+
+mv $PKG/usr/share/man $PKG/usr/man
+gzip $PKG/usr/man/man?/*.?
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+mv $PKG/usr/share/doc/$PRGNAM/html $PKGDOC
+rm -rf $PKG/usr/share/doc/
+find $PKGDOC/html -type f -a -empty | xargs rm
+cp -a CHANGELOG* CONTRIBUTING* README* LICENSE* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/kitty/kitty.info b/system/kitty/kitty.info
new file mode 100644
index 0000000000..aadc6f8ac2
--- /dev/null
+++ b/system/kitty/kitty.info
@@ -0,0 +1,10 @@
+PRGNAM="kitty"
+VERSION="0.34.1"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+DOWNLOAD="https://download.dlackware.com/hosted-sources/kitty/kitty-0.34.1.tar.xz"
+MD5SUM="992c3ed6c2209a4aa8446afda0c8ee72"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="librsync google-go-lang simde"
+MAINTAINER="Eugen Wissner"
+EMAIL="belka@caraus.de"
diff --git a/system/kitty/slack-desc b/system/kitty/slack-desc
new file mode 100644
index 0000000000..7d5c2b81a9
--- /dev/null
+++ b/system/kitty/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kitty: kitty (fast, featureful, GPU-based terminal emulator)
+kitty:
+kitty: kitty is a terminal emulator for X11 and Wayland, which offloads the
+kitty: rendering to the GPU and supports modern terminal features. It also
+kitty: supports tiling multiple terminal windows without using an extra
+kitty: program like screen or tmux.
+kitty:
+kitty: Homepage: https://sw.kovidgoyal.net/kitty/
+kitty:
+kitty:
+kitty: