summaryrefslogtreecommitdiffstats
path: root/system/glances
diff options
context:
space:
mode:
Diffstat (limited to 'system/glances')
-rw-r--r--system/glances/README44
-rw-r--r--system/glances/doinst.sh11
-rw-r--r--system/glances/glances.SlackBuild87
-rw-r--r--system/glances/glances.info10
-rw-r--r--system/glances/slack-desc19
5 files changed, 0 insertions, 171 deletions
diff --git a/system/glances/README b/system/glances/README
deleted file mode 100644
index 120cd17f85..0000000000
--- a/system/glances/README
+++ /dev/null
@@ -1,44 +0,0 @@
-glances is a free (LGPL), cross-platform, curses-based system monitoring tool
-which aims to present a maximum of information in a minimum of space, ideally
-to fit in a classical 80x24 terminal, or larger for additional data. It can
-adapt the displayed information dynamically, depending on the terminal size.
-A client/server mode is also available and remote monitoring can be done via
-terminal or a web interface.
-
-glances is written in Python and uses the psutil library to fetch statistical
-values from key elements, like CPU, load average, memory, network, disks, file
-systems, processes, etc.
-
-OPTIONAL DEPENDENCIES
-
-* Available on SBo:
-batinfo (for battery monitoring support)
-bottle (for web server mode)
-couchdb (for CouchDB export module)
-docker (for Docker monitoring support)
-elasticsearch (for Elastic Search export module)
-hddtemp (for HDD temperature monitoring support)
-matplotlib (for graphical/chart support)
-netifaces (for IP plugin)
-py-cpuinfo (for Quicklook CPU info module)
-pymdstat (for RAID support)
-python-requests (for Ports plugin)
-python-scandir (for Folders plugin)
-statsd (for StatsD export module)
-pysnmp (for SNMP support)
-pyzmq (for ZeroMQ export module)
-
-* Not available on SBo:
-bernhard (for Riemann export module)
-cassandra-driver (for Cassandra export module)
-influxdb (for InfluxDB export module)
-nvidia-ml-py (for GPU plugin)
-pika (for RabbitMQ/ActiveMQ export module)
-potsdb (for OpenTSDB export module)
-pystache (for action scripting)
-wifi (for wifi plugin)
-zeroconf (for autodiscover mode)
-
-NOTE: When launching glances from a terminal with a bright background, the
-option '--theme-white' is recommended. More options are documented in the man
-page and in the file glances.conf.
diff --git a/system/glances/doinst.sh b/system/glances/doinst.sh
deleted file mode 100644
index 4490c14238..0000000000
--- a/system/glances/doinst.sh
+++ /dev/null
@@ -1,11 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- rm $NEW
- fi
-}
-
-config etc/glances.conf.new
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
deleted file mode 100644
index a520b6e3a3..0000000000
--- a/system/glances/glances.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for glances
-
-# Copyright 2013-2017 Philip Lacroix <slackph at posteo dot de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=glances
-VERSION=${VERSION:-2.9.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-PRGETC=$PKG/etc
-PRGUSR=$PKG/usr
-PRGSHR=$PKG/usr/share
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
-# Move and compress man page.
-mv $PRGSHR/man $PRGUSR/
-gzip -9 $PRGUSR/man/man1/$PRGNAM.1
-
-# Safely install configuration file.
-mkdir $PRGETC
-mv $PRGSHR/doc/$PRGNAM/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
-
-# Install documentation.
-mkdir -p $PRGDOC
-mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
-cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
-rm -rf $PRGSHR
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/glances/glances.info b/system/glances/glances.info
deleted file mode 100644
index cf3fe34b48..0000000000
--- a/system/glances/glances.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="glances"
-VERSION="2.9.1"
-HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://github.com/nicolargo/glances/archive/v2.9.1/glances-2.9.1.tar.gz"
-MD5SUM="2e10c6e25f61002bc6d647d3bfcb4d62"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="psutil"
-MAINTAINER="Philip Lacroix"
-EMAIL="slackph at posteo dot de"
diff --git a/system/glances/slack-desc b/system/glances/slack-desc
deleted file mode 100644
index e5b111feec..0000000000
--- a/system/glances/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-glances: glances (a cross-platform, curses-based system monitoring tool)
-glances:
-glances: glances is a cross-platform, curses-based system monitoring tool
-glances: written in Python. It can adapt the displayed information depending
-glances: on the terminal size and can work in a client/server mode for remote
-glances: monitoring. It uses the psutil library to fetch statistical values
-glances: from key elements, like CPU, load average, memory, network, disks,
-glances: file systems, processes, etc.
-glances:
-glances: Homepage: https://github.com/nicolargo/glances
-glances: