summaryrefslogtreecommitdiffstats
path: root/system/doublecmd-qt5
diff options
context:
space:
mode:
Diffstat (limited to 'system/doublecmd-qt5')
-rw-r--r--system/doublecmd-qt5/README8
-rw-r--r--system/doublecmd-qt5/doinst.sh13
-rw-r--r--system/doublecmd-qt5/doublecmd-qt5.SlackBuild131
-rw-r--r--system/doublecmd-qt5/doublecmd-qt5.info10
-rw-r--r--system/doublecmd-qt5/slack-desc19
5 files changed, 181 insertions, 0 deletions
diff --git a/system/doublecmd-qt5/README b/system/doublecmd-qt5/README
new file mode 100644
index 0000000000..34fe9f50be
--- /dev/null
+++ b/system/doublecmd-qt5/README
@@ -0,0 +1,8 @@
+Double Commander (Qt5 version)
+
+Double Commander is a free cross-platform open source file manager
+with two panels side by side (or one above the other). This is the Qt
+version of the program.
+
+Since it is written in Pascal, lazarus, fpc, and libqtpas packages must
+be installed before building.
diff --git a/system/doublecmd-qt5/doinst.sh b/system/doublecmd-qt5/doinst.sh
new file mode 100644
index 0000000000..aea0f894eb
--- /dev/null
+++ b/system/doublecmd-qt5/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/doublecmd-qt5/doublecmd-qt5.SlackBuild b/system/doublecmd-qt5/doublecmd-qt5.SlackBuild
new file mode 100644
index 0000000000..add4b121b6
--- /dev/null
+++ b/system/doublecmd-qt5/doublecmd-qt5.SlackBuild
@@ -0,0 +1,131 @@
+#!/bin/bash
+
+# Copyright (C) 2023 Hao Chi Kiang <no@no.noooo.ooo>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+# revision date: 2023/11/11
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=doublecmd-qt5
+UPSTR_PRGNAME=doublecmd
+VERSION=${VERSION:-1.1.12}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKLAZBUILDFLAGS="--cpu=i386"
+ CPU_TARGET=i386
+elif [ "$ARCH" = "i686" ]; then
+ SLKLAZBUILDFLAGS="--cpu=i386"
+ CPU_TARGET=i386
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKLAZBUILDFLAGS="--cpu=x86_64"
+ CPU_TARGET=$ARCH
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKLAZBUILDFLAGS="--cpu=aarch64"
+ CPU_TARGET=$ARCH
+else
+ SLKLAZBUILDFLAGS=""
+ CPU_TARGET=$ARCH
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+tar -zxvf $CWD/$UPSTR_PRGNAME-$VERSION-src.tar.gz
+cd $UPSTR_PRGNAME-$VERSION
+
+# 20240113 ALe: this symlink is mistargeted... removed
+rm -rf doublecmd.app/Contents/MacOS/doublecmd
+
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+# Build it. Adapted from
+# https://gitlab.archlinux.org/archlinux/packaging/packages/doublecmd/-/blob/5afa60350dcbce809f26081537032c70620e91e1/PKGBUILD
+cp -a /usr/share/lazarus ./
+sed -e 's/LIB_SUFFIX=.*/LIB_SUFFIX=/g' -i install/linux/install.sh
+sed -e "s@=\$(which lazbuild)@=\"\$(which lazbuild) --lazarusdir=$(pwd)/lazarus\"@" -i build.sh
+sed -e '/doublecmd.zdli/d' -i install/linux/install.sh
+lcl=qt5 CPU_TARGET=$CPU_TARGET ./build.sh components
+lcl=qt5 CPU_TARGET=$CPU_TARGET ./build.sh plugins
+/usr/bin/lazbuild \
+ $SLKLAZBUILDFLAGS \
+ --lazarusdir="$(pwd)/lazarus" \
+ src/doublecmd.lpi \
+ --bm="NoDebug Full Optimizations" \
+ --widgetset=qt5
+
+# Install it into the package
+chmod +x ./install/linux/install.sh
+sed -i "s|share/doublecmd/doc|doc/${PRGNAM}-${VERSION}|g" ./install/linux/install.sh
+sed -i "s|share/man|man|g" ./install/linux/install.sh
+./install/linux/install.sh --install-prefix="$PKG"
+
+# make plugins executable:
+chmod -R +x $PKG/usr/lib/doublecmd/plugins/*
+
+# Strip everything.
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Gzip man page
+gzip $PKG/usr/man/man1/doublecmd.1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/doublecmd-qt5/doublecmd-qt5.info b/system/doublecmd-qt5/doublecmd-qt5.info
new file mode 100644
index 0000000000..1703ce0fbd
--- /dev/null
+++ b/system/doublecmd-qt5/doublecmd-qt5.info
@@ -0,0 +1,10 @@
+PRGNAM="doublecmd-qt5"
+VERSION="1.1.12"
+HOMEPAGE="http://doublecmd.sourceforge.net/"
+DOWNLOAD="https://downloads.sourceforge.net/project/doublecmd/Double%20Commander%20Source/doublecmd-1.1.12-src.tar.gz"
+MD5SUM="c3a5c06c9ba44b51d454aca00b42ca4c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lazarus libqtpas"
+MAINTAINER="Hao Chi Kiang"
+EMAIL="no@no.noooo.ooo"
diff --git a/system/doublecmd-qt5/slack-desc b/system/doublecmd-qt5/slack-desc
new file mode 100644
index 0000000000..79c23af8e0
--- /dev/null
+++ b/system/doublecmd-qt5/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+doublecmd-qt5: doublecmd-qt5 (Double-panel File Manager)
+doublecmd-qt5:
+doublecmd-qt5: Double Commander is a free cross-platform open source file manager
+doublecmd-qt5: with two panels side by side (or one above the other). This is the Qt
+doublecmd-qt5: version of the program.
+doublecmd-qt5:
+doublecmd-qt5: Since it is written in Pascal, lazarus, fpc, and qt5pas packages must
+doublecmd-qt5: be installed before building.
+doublecmd-qt5:
+doublecmd-qt5: Homepage at http://doublecmd.sourceforge.net
+doublecmd-qt5: