summaryrefslogtreecommitdiffstats
path: root/system/dlm/patches
diff options
context:
space:
mode:
Diffstat (limited to 'system/dlm/patches')
-rw-r--r--system/dlm/patches/Check-sscanf-return-value.patch24
-rw-r--r--system/dlm/patches/Use-CPPFLAGS-from-the-environment.patch18
-rw-r--r--system/dlm/patches/series1
3 files changed, 5 insertions, 38 deletions
diff --git a/system/dlm/patches/Check-sscanf-return-value.patch b/system/dlm/patches/Check-sscanf-return-value.patch
deleted file mode 100644
index 719e294fca..0000000000
--- a/system/dlm/patches/Check-sscanf-return-value.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Valentin Vidic <Valentin.Vidic@CARNet.hr>
-Date: Wed, 25 Apr 2018 23:13:29 +0200
-Subject: Check sscanf return value
-
----
- dlm_tool/main.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/dlm_tool/main.c b/dlm_tool/main.c
-index 042caa9..1900236 100644
---- a/dlm_tool/main.c
-+++ b/dlm_tool/main.c
-@@ -692,6 +692,11 @@ static void print_lkb(char *line, struct rinfo *ri)
- (unsigned long long *)&lkb.timestamp,
- (unsigned long long *)&lkb.time_bast);
-
-+ if (rv != 17) {
-+ fprintf(stderr, "print_lkb error rv %d line \"%s\"\n", rv, line);
-+ return;
-+ }
-+
- ri->lkb_count++;
-
- if (lkb.status == DLM_LKSTS_GRANTED) {
diff --git a/system/dlm/patches/Use-CPPFLAGS-from-the-environment.patch b/system/dlm/patches/Use-CPPFLAGS-from-the-environment.patch
index 7f32d838d2..d4e9f5bd89 100644
--- a/system/dlm/patches/Use-CPPFLAGS-from-the-environment.patch
+++ b/system/dlm/patches/Use-CPPFLAGS-from-the-environment.patch
@@ -9,12 +9,10 @@ Subject: Use CPPFLAGS from the environment
libdlm/Makefile | 4 ++--
4 files changed, 6 insertions(+), 6 deletions(-)
-diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
-index 75c5750..47af929 100644
--- a/dlm_controld/Makefile
+++ b/dlm_controld/Makefile
-@@ -58,10 +58,10 @@ endif
- all: $(LIB_TARGET) $(BIN_TARGET)
+@@ -62,10 +62,10 @@
+ all: $(LIB_TARGET) $(BIN_TARGET) $(LIB_PC)
$(BIN_TARGET): $(BIN_SOURCE)
- $(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@ -L.
@@ -26,11 +24,9 @@ index 75c5750..47af929 100644
ln -sf $(LIB_TARGET) $(LIB_SO)
ln -sf $(LIB_TARGET) $(LIB_SMAJOR)
-diff --git a/dlm_tool/Makefile b/dlm_tool/Makefile
-index 80d7725..a9b3be0 100644
--- a/dlm_tool/Makefile
+++ b/dlm_tool/Makefile
-@@ -27,7 +27,7 @@ LDFLAGS += -lpthread -ldlm -ldlmcontrol
+@@ -27,7 +27,7 @@
all: $(BIN_TARGET)
$(BIN_TARGET): $(BIN_SOURCE)
@@ -39,11 +35,9 @@ index 80d7725..a9b3be0 100644
clean:
rm -f *.o *.so *.so.* $(BIN_TARGET)
-diff --git a/fence/Makefile b/fence/Makefile
-index b927879..d4a3c09 100644
--- a/fence/Makefile
+++ b/fence/Makefile
-@@ -28,7 +28,7 @@ LDFLAGS += -ldl
+@@ -28,7 +28,7 @@
all: $(BIN_TARGET)
$(BIN_TARGET): $(BIN_SOURCE)
@@ -52,11 +46,9 @@ index b927879..d4a3c09 100644
clean:
rm -f *.o *.so *.so.* $(BIN_TARGET)
-diff --git a/libdlm/Makefile b/libdlm/Makefile
-index ab32761..21addf8 100644
--- a/libdlm/Makefile
+++ b/libdlm/Makefile
-@@ -90,10 +90,10 @@ LLT_LDFLAGS += $(LDFLAGS)
+@@ -90,10 +90,10 @@
all: $(LIB_TARGET) $(LLT_TARGET) $(LIB_PC) $(LLT_PC)
$(LIB_O): $(SOURCE)
diff --git a/system/dlm/patches/series b/system/dlm/patches/series
index 3b61b57b9b..17ef4f6ee0 100644
--- a/system/dlm/patches/series
+++ b/system/dlm/patches/series
@@ -2,4 +2,3 @@ Debian-path-for-the-config-file.patch
Enable-systemctl-help-dlm-to-show-relevant-man-pages.patch
Use-CPPFLAGS-from-the-environment.patch
Don-t-link-dlm_stonith-against-libxml2.patch
-Check-sscanf-return-value.patch