summaryrefslogtreecommitdiffstats
path: root/system/cyberjack
diff options
context:
space:
mode:
Diffstat (limited to 'system/cyberjack')
-rw-r--r--system/cyberjack/README5
-rw-r--r--system/cyberjack/cyberjack.SlackBuild124
-rw-r--r--system/cyberjack/cyberjack.info10
-rw-r--r--system/cyberjack/slack-desc19
4 files changed, 158 insertions, 0 deletions
diff --git a/system/cyberjack/README b/system/cyberjack/README
new file mode 100644
index 0000000000..858bcbdbce
--- /dev/null
+++ b/system/cyberjack/README
@@ -0,0 +1,5 @@
+ReinerSCT cyberJack USB chipcard reader driver.
+
+This driver allows you to use ReinerSCT chipcard readers from user
+space. It does not include a driver for the ReinerSCT cyberJack
+RFID basis.
diff --git a/system/cyberjack/cyberjack.SlackBuild b/system/cyberjack/cyberjack.SlackBuild
new file mode 100644
index 0000000000..f33220158d
--- /dev/null
+++ b/system/cyberjack/cyberjack.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+
+# Slackware build script for cyberjack
+
+# Copyright 2024 n1to <n1to-slack@posteo.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=cyberjack
+VERSION=${VERSION:-3.99.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=pcsc-${PRGNAM}-${VERSION}final.SP16
+SRCDNAM=pcsc-${PRGNAM}-${VERSION}final.SP16
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM.tar.bz2
+cd $SRCDNAM
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --enable-udev \
+ --enable-release \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/pcsc/drivers/libifd-cyberjack.bundle/Contents/Linux/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYRIGHT.GPL \
+ COPYRIGHT.LGPL \
+ debian/changelog \
+ doc/README.txt \
+ doc/verifypin_ascii.c \
+ doc/verifypin_fpin2.c \
+ doc/verify_pin_direct.cpp \
+ doc/modify_pin_direct.cpp \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/cyberjack/cyberjack.info b/system/cyberjack/cyberjack.info
new file mode 100644
index 0000000000..20a7dadd74
--- /dev/null
+++ b/system/cyberjack/cyberjack.info
@@ -0,0 +1,10 @@
+PRGNAM="cyberjack"
+VERSION="3.99.5"
+HOMEPAGE="https://www.reiner-sct.com"
+DOWNLOAD="https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP16/pcsc-cyberjack-3.99.5final.SP16.tar.bz2"
+MD5SUM="462f141acfa8d9c94b97677018a3f159"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pcsc-lite"
+MAINTAINER="n1to"
+EMAIL="n1to-slack@posteo.net"
diff --git a/system/cyberjack/slack-desc b/system/cyberjack/slack-desc
new file mode 100644
index 0000000000..305aab3b66
--- /dev/null
+++ b/system/cyberjack/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cyberjack: cyberjack (driver for cyberJack card reader)
+cyberjack:
+cyberjack: Drivers for ReinerSCT cyberJack card reader devices.
+cyberjack:
+cyberjack: Homepage: https://www.reiner-sct.com
+cyberjack:
+cyberjack:
+cyberjack:
+cyberjack:
+cyberjack:
+cyberjack: