summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/suds-jurko/README8
-rw-r--r--python/suds-jurko/suds-jurko.SlackBuild5
2 files changed, 13 insertions, 0 deletions
diff --git a/python/suds-jurko/README b/python/suds-jurko/README
index 488a5481d0..3c88d60ff3 100644
--- a/python/suds-jurko/README
+++ b/python/suds-jurko/README
@@ -1,2 +1,10 @@
suds-jurko is a fork of suds, a lightweight SOAP-based
web service client for Python.
+
+python3 is an optional dependency.
+
+If you want to build the package with python3 support
+you have to pass the PYTHON3 parameter to the script
+as follows:
+
+ PYTHON3=yes ./suds-jurko.SlackBuild
diff --git a/python/suds-jurko/suds-jurko.SlackBuild b/python/suds-jurko/suds-jurko.SlackBuild
index d360c390d5..cc69205017 100644
--- a/python/suds-jurko/suds-jurko.SlackBuild
+++ b/python/suds-jurko/suds-jurko.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Install python3 bindings. Default is no.
+if [ "${PYTHON3:-no}" = "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true