summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Cristiano Urban2019-03-03 02:57:19 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:12 +0100
commit3ec87518bf31a751a19427cbab665c4ff0053da4 (patch)
treefb5bddd5984e4102877aa0b12e8922005d68b093 /python
parent1e9843d5f937d014d3c60c8a079d7e9239bf0d84 (diff)
downloadslackbuilds-3ec87518bf31a751a19427cbab665c4ff0053da4.tar.gz
python/suds-jurko: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/suds-jurko/README8
-rw-r--r--python/suds-jurko/suds-jurko.SlackBuild5
2 files changed, 13 insertions, 0 deletions
diff --git a/python/suds-jurko/README b/python/suds-jurko/README
index 488a5481d0..3c88d60ff3 100644
--- a/python/suds-jurko/README
+++ b/python/suds-jurko/README
@@ -1,2 +1,10 @@
suds-jurko is a fork of suds, a lightweight SOAP-based
web service client for Python.
+
+python3 is an optional dependency.
+
+If you want to build the package with python3 support
+you have to pass the PYTHON3 parameter to the script
+as follows:
+
+ PYTHON3=yes ./suds-jurko.SlackBuild
diff --git a/python/suds-jurko/suds-jurko.SlackBuild b/python/suds-jurko/suds-jurko.SlackBuild
index d360c390d5..cc69205017 100644
--- a/python/suds-jurko/suds-jurko.SlackBuild
+++ b/python/suds-jurko/suds-jurko.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Install python3 bindings. Default is no.
+if [ "${PYTHON3:-no}" = "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true