summaryrefslogtreecommitdiffstats
path: root/python/thonny
diff options
context:
space:
mode:
Diffstat (limited to 'python/thonny')
-rw-r--r--python/thonny/doinst.sh6
-rw-r--r--python/thonny/thonny.SlackBuild60
-rw-r--r--python/thonny/thonny.info8
3 files changed, 37 insertions, 37 deletions
diff --git a/python/thonny/doinst.sh b/python/thonny/doinst.sh
index 5fb28930db..65c7e2eeb9 100644
--- a/python/thonny/doinst.sh
+++ b/python/thonny/doinst.sh
@@ -1,3 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 44a0e62eeb..4f7aa038a7 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -1,6 +1,6 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for thonny
-# Copyright 2017-21 Tim Dickson, Scotland
+# Copyright 2017-23 Tim Dickson, Scotland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -20,37 +20,22 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#version history
+#version history -edited down in size to first and last 4 updates
#2.2.0b4 1 jan 2018. first version for slackbuilds.org
-#3.0.5 1 nov 2018. addition of lots of deps.
-#3.0.8 16 nov 2018. version bump.
-#3.1.0 31 jan 2019. version bump.
-#3.1.1 10 Feb 2019. version bump.
-#3.1.2 14 Feb 2019. version bump.
-#3.2.0b1 25 jun 2019. version bump.
-#3.2.0b7 22 Jul 2019. version bump.
-#3.2.0 12 Aug 2019. release version.
-#3.2.1 6 Sep 2019. version bump.
-#3.2.2 2 Nov 2019. version bump. added new dep. asttokens
-#3.2.3 4 Nov 2019. version bump.
-#3.2.4 10 Dec 2019. version bump.
-#3.2.5 25 Dec 2019. version bump. added extra dep. send2trash
-#add optional dep on pygame with python3 support. common for python learners
-#which thonny is targetted at.
-#3.2.6 06 Jan 2020. version bump. also added optional dep of esptool
-#3.2.7 23 Jan 2020. version bump. added dep of python-distro
-#3.3.0 16 Nov 2020. version bump.
-#3.3.1 7 Dec 2020. version bump.
-#3.3.2 14 Jan 2021. version bump.
-#3.3.3 27 Jan 2021. version bump.
+#editted out :-)
+#4.1.2 16 Aug 2023. version bump
+#4.1.3 5 Oct 2023. version bump
+#4.1.3 build2 27 Oct 2023. change deps.
+#4.1.4 8 Dec 2023. version bump
+
#note. get download link from https://pypi.org/project/thonny/#files
-#build2 10 Feb 2021. move install location to allow a plugin to work.
-#thanks to chrisw. changed build arch as install is arch specific now.
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=thonny
-VERSION=${VERSION:-3.3.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.1.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -60,7 +45,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -85,9 +77,11 @@ find -L . \
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-mkdir -p $PKG/usr/share/pixmaps
-cp -a packaging/icons/$PRGNAM-*.png $PKG/usr/share/pixmaps/
-cp -a packaging/icons/$PRGNAM-128x128.png $PKG/usr/share/pixmaps/$PRGNAM.png
+mkdir -p $PKG/usr/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128,192x192,256x256}/apps
+for i in `ls packaging/icons/$PRGNAM-*x*.png`; do
+ IDIR=`echo $i|awk -F"-" '{print $2}'|awk -F"." '{print $1}'`
+ cp -a $i $PKG/usr/share/icons/hicolor/$IDIR/apps/$PRGNAM.png
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
for i in CREDITS.rst README.rst CHANGELOG.rst LICENSE.txt; do
cp $i $PKG/usr/doc/$PRGNAM-$VERSION
@@ -99,4 +93,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/thonny/thonny.info b/python/thonny/thonny.info
index 651c1d249e..6ab6c04ef7 100644
--- a/python/thonny/thonny.info
+++ b/python/thonny/thonny.info
@@ -1,10 +1,10 @@
PRGNAM="thonny"
-VERSION="3.3.3"
+VERSION="4.1.4"
HOMEPAGE="http://thonny.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/91/79/29353fde3dd505cfc9e01bd419c52c6a0d20052b5a5f3566930a6d126405/thonny-3.3.3.tar.gz"
-MD5SUM="7685b1be523762125cc0e4bce0d04ef0"
+DOWNLOAD="https://files.pythonhosted.org/packages/4e/82/994a3aa41bc32b37c9b53fa4fa0c7ad0a6a0f586d85e71f2e2220d1b4c61/thonny-4.1.4.tar.gz"
+MD5SUM="3223eca53ea5b681afb45d0615565d1d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-jedi docutils python3-pylint pyserial mypy_extensions asttokens send2trash python-distro"
+REQUIRES="python3-jedi python3-pylint pyserial mypy python3-asttokens send2trash"
MAINTAINER="Tim Dickson"
EMAIL="dickson.tim@googlemail.com"