summaryrefslogtreecommitdiffstats
path: root/python/terminado
diff options
context:
space:
mode:
Diffstat (limited to 'python/terminado')
-rw-r--r--python/terminado/README4
-rw-r--r--python/terminado/terminado.SlackBuild40
-rw-r--r--python/terminado/terminado.info14
3 files changed, 25 insertions, 33 deletions
diff --git a/python/terminado/README b/python/terminado/README
index e42d4a4779..54baa522ae 100644
--- a/python/terminado/README
+++ b/python/terminado/README
@@ -1,2 +1,2 @@
-Terminado is a Tornado websocket backend for the term.js Javascript terminal
-emulator library.
+Terminado is a Tornado websocket backend for the term.js Javascript
+terminal emulator library.
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index 94bb2da8d4..5992c8be24 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for terminado
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=terminado
-VERSION=${VERSION:-0.8.2}
+VERSION=${VERSION:-0.18.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,25 +39,15 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -69,20 +63,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/terminado/terminado.info b/python/terminado/terminado.info
index fbb25fe6bf..7e61fcaa57 100644
--- a/python/terminado/terminado.info
+++ b/python/terminado/terminado.info
@@ -1,10 +1,10 @@
PRGNAM="terminado"
-VERSION="0.8.2"
-HOMEPAGE="https://terminado.readthedocs.io/en/latest/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.8.2.tar.gz"
-MD5SUM="933a1c5ca7c28e59284d0ac7cadce1ea"
+VERSION="0.18.1"
+HOMEPAGE="https://github.com/jupyter/terminado"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.18.1.tar.gz"
+MD5SUM="9b411cdada4fe129e60c75f95d17ffa9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-ptyprocess python3-tornado ptyprocess tornado"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-ptyprocess python3-tornado python3-hatchling"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"