summaryrefslogtreecommitdiffstats
path: root/python/termcolor/termcolor.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/termcolor/termcolor.SlackBuild')
-rw-r--r--python/termcolor/termcolor.SlackBuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/python/termcolor/termcolor.SlackBuild b/python/termcolor/termcolor.SlackBuild
index b60b8e3817..9059093447 100644
--- a/python/termcolor/termcolor.SlackBuild
+++ b/python/termcolor/termcolor.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for termcolor
-# Copyright 2013-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2013-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=termcolor
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-2.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,17 +79,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO COPYING.txt CHANGES.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md PKG-INFO COPYING.txt CHANGES.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install