summaryrefslogtreecommitdiffstats
path: root/python/pyxdg
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyxdg')
-rw-r--r--python/pyxdg/README3
-rw-r--r--python/pyxdg/pyxdg.SlackBuild75
-rw-r--r--python/pyxdg/pyxdg.info10
-rw-r--r--python/pyxdg/slack-desc19
4 files changed, 0 insertions, 107 deletions
diff --git a/python/pyxdg/README b/python/pyxdg/README
deleted file mode 100644
index b42e24ed4f..0000000000
--- a/python/pyxdg/README
+++ /dev/null
@@ -1,3 +0,0 @@
-PyXDG contains implementations of freedesktop.org standards in python.
-
-Python3 is an optional dependency.
diff --git a/python/pyxdg/pyxdg.SlackBuild b/python/pyxdg/pyxdg.SlackBuild
deleted file mode 100644
index 2e616b739c..0000000000
--- a/python/pyxdg/pyxdg.SlackBuild
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for PyXDG
-
-# Copyright 2008-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# Copyright 2016, 2018 Hunter Sezen California, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyxdg
-VERSION=${VERSION:-0.26}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-# Python 3 support.
-if python3 -c 'import sys' 2>/dev/null; then
- python3 setup.py install --root=$PKG
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL PKG-INFO README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyxdg/pyxdg.info b/python/pyxdg/pyxdg.info
deleted file mode 100644
index a5438fe7cc..0000000000
--- a/python/pyxdg/pyxdg.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyxdg"
-VERSION="0.26"
-HOMEPAGE="http://freedesktop.org/wiki/Software/pyxdg"
-DOWNLOAD="https://pypi.python.org/packages/47/6e/311d5f22e2b76381719b5d0c6e9dc39cd33999adae67db71d7279a6d70f4/pyxdg-0.26.tar.gz"
-MD5SUM="db1c2af8300ca64ce3955b3cf2490c92"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@riseup.net"
diff --git a/python/pyxdg/slack-desc b/python/pyxdg/slack-desc
deleted file mode 100644
index 92074cd35e..0000000000
--- a/python/pyxdg/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyxdg: pyxdg (Python XDG Library)
-pyxdg:
-pyxdg: PyXDG contains implementations of freedesktop.org standards in python.
-pyxdg:
-pyxdg: Homepage: http://freedesktop.org/wiki/Software/pyxdg
-pyxdg:
-pyxdg:
-pyxdg:
-pyxdg:
-pyxdg:
-pyxdg: