summaryrefslogtreecommitdiffstats
path: root/python/python3/patches
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3/patches')
-rw-r--r--python/python3/patches/python3.no-static-library.diff50
-rw-r--r--python/python3/patches/python3.readline.set_pre_input_hook.diff12
-rw-r--r--python/python3/patches/python3.x86_64.diff156
3 files changed, 0 insertions, 218 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
deleted file mode 100644
index 2e03ab8add..0000000000
--- a/python/python3/patches/python3.no-static-library.diff
+++ /dev/null
@@ -1,50 +0,0 @@
---- ./Makefile.pre.in.orig 2019-01-13 13:06:37.518767495 -0600
-+++ ./Makefile.pre.in 2019-01-13 13:28:41.778781670 -0600
-@@ -549,7 +549,7 @@
- $(PYTHON_FOR_REGEN) ./Tools/clinic/clinic.py --make
-
- # Build the interpreter
--$(BUILDPYTHON): Programs/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
-+$(BUILDPYTHON): Programs/python.o $(LDLIBRARY) $(PY3LIBRARY)
- $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
-
- platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -598,11 +598,6 @@
- $(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
-
-
--# Build static library
--$(LIBRARY): $(LIBRARY_OBJS)
-- -rm -f $@
-- $(AR) $(ARFLAGS) $@ $(LIBRARY_OBJS)
--
- libpython$(LDVERSION).so: $(LIBRARY_OBJS)
- if test $(INSTSONAME) != $(LDLIBRARY); then \
- $(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -692,7 +687,7 @@
- echo "-----------------------------------------------"; \
- fi
-
--Programs/_testembed: Programs/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
-+Programs/_testembed: Programs/_testembed.o $(LDLIBRARY) $(PY3LIBRARY)
- $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
-
- ############################################################################
-@@ -1428,17 +1423,6 @@
- else true; \
- fi; \
- done
-- @if test -d $(LIBRARY); then :; else \
-- if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
-- if test "$(SHLIB_SUFFIX)" = .dll; then \
-- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
-- else \
-- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
-- fi; \
-- else \
-- echo Skip install of $(LIBRARY) - use make frameworkinstall; \
-- fi; \
-- fi
- $(INSTALL_DATA) Modules/config.c $(DESTDIR)$(LIBPL)/config.c
- $(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
- $(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
diff --git a/python/python3/patches/python3.readline.set_pre_input_hook.diff b/python/python3/patches/python3.readline.set_pre_input_hook.diff
deleted file mode 100644
index b55820c489..0000000000
--- a/python/python3/patches/python3.readline.set_pre_input_hook.diff
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./Modules/readline.c.orig 2009-10-26 21:32:51.000000000 +0200
-+++ ./Modules/readline.c 2010-05-30 14:07:10.000000000 +0300
-@@ -12,6 +12,9 @@
- #include <errno.h>
- #include <sys/time.h>
-
-+/* This seems to be needed for set_pre_input_hook to work */
-+#define HAVE_RL_PRE_INPUT_HOOK 1
-+
- #if defined(HAVE_SETLOCALE)
- /* GNU readline() mistakenly sets the LC_CTYPE locale.
- * This is evil. Only the user or the app's main() should do this!
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
deleted file mode 100644
index 1649c2344a..0000000000
--- a/python/python3/patches/python3.x86_64.diff
+++ /dev/null
@@ -1,156 +0,0 @@
---- ./configure.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./configure 2019-02-19 16:02:14.585002930 -0600
-@@ -15149,9 +15149,9 @@
-
-
- if test x$PLATFORM_TRIPLET = x; then
-- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
-+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
- else
-- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
-+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
- fi
-
-
---- ./Makefile.pre.in.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./Makefile.pre.in 2019-02-19 16:02:14.576002930 -0600
-@@ -142,7 +142,7 @@
- MANDIR= @mandir@
- INCLUDEDIR= @includedir@
- CONFINCLUDEDIR= $(exec_prefix)/include
--SCRIPTDIR= $(prefix)/lib
-+SCRIPTDIR= $(prefix)/lib64
- ABIFLAGS= @ABIFLAGS@
-
- # Detailed destination directories
---- ./Lib/sysconfig.py.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./Lib/sysconfig.py 2019-02-19 16:02:14.574002930 -0600
-@@ -20,10 +20,10 @@
-
- _INSTALL_SCHEMES = {
- 'posix_prefix': {
-- 'stdlib': '{installed_base}/lib/python{py_version_short}',
-- 'platstdlib': '{platbase}/lib/python{py_version_short}',
-- 'purelib': '{base}/lib/python{py_version_short}/site-packages',
-- 'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
-+ 'stdlib': '{installed_base}/lib64/python{py_version_short}',
-+ 'platstdlib': '{platbase}/lib64/python{py_version_short}',
-+ 'purelib': '{base}/lib64/python{py_version_short}/site-packages',
-+ 'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
- 'include':
- '{installed_base}/include/python{py_version_short}{abiflags}',
- 'platinclude':
-@@ -32,10 +32,10 @@
- 'data': '{base}',
- },
- 'posix_home': {
-- 'stdlib': '{installed_base}/lib/python',
-- 'platstdlib': '{base}/lib/python',
-- 'purelib': '{base}/lib/python',
-- 'platlib': '{base}/lib/python',
-+ 'stdlib': '{installed_base}/lib64/python',
-+ 'platstdlib': '{base}/lib64/python',
-+ 'purelib': '{base}/lib64/python',
-+ 'platlib': '{base}/lib64/python',
- 'include': '{installed_base}/include/python',
- 'platinclude': '{installed_base}/include/python',
- 'scripts': '{base}/bin',
-@@ -62,10 +62,10 @@
- 'data': '{userbase}',
- },
- 'posix_user': {
-- 'stdlib': '{userbase}/lib/python{py_version_short}',
-- 'platstdlib': '{userbase}/lib/python{py_version_short}',
-- 'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
-- 'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
-+ 'stdlib': '{userbase}/lib64/python{py_version_short}',
-+ 'platstdlib': '{userbase}/lib64/python{py_version_short}',
-+ 'purelib': '{userbase}/lib64/python{py_version_short}/site-packages',
-+ 'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
- 'include': '{userbase}/include/python{py_version_short}',
- 'scripts': '{userbase}/bin',
- 'data': '{userbase}',
---- ./Lib/site.py.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./Lib/site.py 2019-02-19 16:02:14.572002930 -0600
-@@ -334,7 +334,7 @@
- seen.add(prefix)
-
- if os.sep == '/':
-- sitepackages.append(os.path.join(prefix, "lib",
-+ sitepackages.append(os.path.join(prefix, "lib64",
- "python%d.%d" % sys.version_info[:2],
- "site-packages"))
- else:
---- ./Lib/distutils/command/install.py.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./Lib/distutils/command/install.py 2019-02-19 16:02:14.567002930 -0600
-@@ -29,15 +29,15 @@
-
- INSTALL_SCHEMES = {
- 'unix_prefix': {
-- 'purelib': '$base/lib/python$py_version_short/site-packages',
-- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
-+ 'purelib': '$base/lib64/python$py_version_short/site-packages',
-+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
- 'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
- },
- 'unix_home': {
-- 'purelib': '$base/lib/python',
-- 'platlib': '$base/lib/python',
-+ 'purelib': '$base/lib64/python',
-+ 'platlib': '$base/lib64/python',
- 'headers': '$base/include/python/$dist_name',
- 'scripts': '$base/bin',
- 'data' : '$base',
---- ./Lib/distutils/sysconfig.py.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./Lib/distutils/sysconfig.py 2019-02-19 16:02:14.570002930 -0600
-@@ -130,7 +130,7 @@
-
- if os.name == "posix":
- libpython = os.path.join(prefix,
-- "lib", "python" + get_python_version())
-+ "lib64", "python" + get_python_version())
- if standard_lib:
- return libpython
- else:
---- ./Modules/getpath.c.orig 2019-02-19 16:02:14.580002930 -0600
-+++ ./Modules/getpath.c 2019-02-19 16:06:51.535002940 -0600
-@@ -500,7 +500,7 @@
- "Could not find platform dependent libraries <exec_prefix>\n");
- }
- wcsncpy(exec_prefix, calculate->exec_prefix, MAXPATHLEN);
-- joinpath(exec_prefix, L"lib/lib-dynload");
-+ joinpath(exec_prefix, L"lib64/lib-dynload");
- }
- /* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
- }
-@@ -742,7 +742,7 @@
- else {
- wcsncpy(calculate->zip_path, calculate->prefix, MAXPATHLEN);
- }
-- joinpath(calculate->zip_path, L"lib/python00.zip");
-+ joinpath(calculate->zip_path, L"lib64/python00.zip");
-
- /* Replace "00" with version */
- size_t bufsz = wcslen(calculate->zip_path);
-@@ -867,7 +867,7 @@
- if (!calculate->prefix) {
- return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
- }
-- calculate->lib_python = Py_DecodeLocale("lib/python" VERSION, &len);
-+ calculate->lib_python = Py_DecodeLocale("lib64/python" VERSION, &len);
- if (!calculate->lib_python) {
- return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
- }
---- ./setup.py.orig 2018-12-23 15:37:36.000000000 -0600
-+++ ./setup.py 2019-02-19 16:02:14.587002930 -0600
-@@ -546,7 +546,7 @@
- # directories (i.e. '.' and 'Include') must be first. See issue
- # 10520.
- if not cross_compiling:
-- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
- # only change this for cross builds for 3.3, issues on Mageia
- if cross_compiling: