summaryrefslogtreecommitdiffstats
path: root/python/python3-soupsieve
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-soupsieve')
-rw-r--r--python/python3-soupsieve/README13
-rw-r--r--python/python3-soupsieve/python3-soupsieve.SlackBuild47
-rw-r--r--python/python3-soupsieve/python3-soupsieve.info12
3 files changed, 38 insertions, 34 deletions
diff --git a/python/python3-soupsieve/README b/python/python3-soupsieve/README
index c06df69832..a294930611 100644
--- a/python/python3-soupsieve/README
+++ b/python/python3-soupsieve/README
@@ -1,6 +1,9 @@
-Soup Sieve is a CSS selector library designed to be used with Beautiful
-Soup 4. It aims to provide selecting, matching, and filtering using
-modern CSS selectors.
+Soup Sieve is a CSS selector library designed to be used with
+Beautiful Soup 4. It aims to provide selecting, matching, and
+filtering using modern CSS selectors.
-Soup Sieve >= 2.0.0 has dropped Python 2 support. The python-soupsieve
-SlackBuild is available at version 1.9.6.
+Soup Sieve >= 2.0.0 has dropped Python 2 support. The
+python-soupsieve SlackBuild is available at version 1.9.6.
+
+python3-build, python3-hatchling, python3-installer are
+dependencies required for the build only.
diff --git a/python/python3-soupsieve/python3-soupsieve.SlackBuild b/python/python3-soupsieve/python3-soupsieve.SlackBuild
index 843e3b49b3..8bf2d9e5a7 100644
--- a/python/python3-soupsieve/python3-soupsieve.SlackBuild
+++ b/python/python3-soupsieve/python3-soupsieve.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-soupsieve
-# Copyright 2020-2021 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2023 Giancarlo Dessi, Cagliari, IT, <slack@giand.it>
+# Copyright 2020-2022 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220415 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - clean up the doc dir.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-soupsieve
-VERSION=${VERSION:-2.2}
+VERSION=${VERSION:-2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=soupsieve
@@ -37,25 +44,15 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -67,21 +64,25 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220415 bkw: since we can't build the HTML docs from the markdown
+# source (we lack the tools), just put the markdown files in the doc dir.
+# they're pretty readable as-is.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md docs/ requirements/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md docs/src/markdown/{*.md,selectors,about} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-soupsieve/python3-soupsieve.info b/python/python3-soupsieve/python3-soupsieve.info
index c1c740cb12..1bc97baec6 100644
--- a/python/python3-soupsieve/python3-soupsieve.info
+++ b/python/python3-soupsieve/python3-soupsieve.info
@@ -1,10 +1,10 @@
PRGNAM="python3-soupsieve"
-VERSION="2.2"
+VERSION="2.5"
HOMEPAGE="https://github.com/facelessuser/soupsieve"
-DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.2/soupsieve-2.2.tar.gz"
-MD5SUM="ddf2b77f00e0e9963326480060c0ef5a"
+DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.5/soupsieve-2.5.tar.gz"
+MD5SUM="b2d9add32560a781ade688c4513458c6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-hatchling"
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"