summaryrefslogtreecommitdiffstats
path: root/python/python3-pypresence
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pypresence')
-rw-r--r--python/python3-pypresence/README3
-rw-r--r--python/python3-pypresence/python3-pypresence.SlackBuild102
-rw-r--r--python/python3-pypresence/python3-pypresence.info10
-rw-r--r--python/python3-pypresence/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/python/python3-pypresence/README b/python/python3-pypresence/README
new file mode 100644
index 0000000000..1063ab9706
--- /dev/null
+++ b/python/python3-pypresence/README
@@ -0,0 +1,3 @@
+A Discord RPC library in Python.
+
+By ~red
diff --git a/python/python3-pypresence/python3-pypresence.SlackBuild b/python/python3-pypresence/python3-pypresence.SlackBuild
new file mode 100644
index 0000000000..b38e0c2249
--- /dev/null
+++ b/python/python3-pypresence/python3-pypresence.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Slackware build script for python3-pypresence
+
+# Copyright 2019-2020 Pouria Rezaei <Pouria.rz@outlook.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pypresence
+SRCNAM=pypresence
+VERSION=${VERSION:-4.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cat $CWD/README > $PRGDOC/README
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pypresence/python3-pypresence.info b/python/python3-pypresence/python3-pypresence.info
new file mode 100644
index 0000000000..a3135b57ee
--- /dev/null
+++ b/python/python3-pypresence/python3-pypresence.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pypresence"
+VERSION="4.2.1"
+HOMEPAGE="https://github.com/qwertyquerty/pypresence"
+DOWNLOAD="https://files.pythonhosted.org/packages/58/df/be2dbd7ed2262791536278295d3c4e56d5c17d4291666f35fd6190a7f2ab/pypresence-4.2.1.tar.gz"
+MD5SUM="14ebd0486238cda6e3a6ec3337751ad9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pouria Rezaei"
+EMAIL="Pouria.rz@outlook.com"
diff --git a/python/python3-pypresence/slack-desc b/python/python3-pypresence/slack-desc
new file mode 100644
index 0000000000..1b312fe8af
--- /dev/null
+++ b/python/python3-pypresence/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pypresence: python3-pypresence (Pypresence Python3 library)
+python3-pypresence:
+python3-pypresence: A Discord RPC library in Python.
+python3-pypresence:
+python3-pypresence:
+python3-pypresence:
+python3-pypresence:
+python3-pypresence:
+python3-pypresence:
+python3-pypresence:
+python3-pypresence: https://github.com/qwertyquerty/pypresence