summaryrefslogtreecommitdiffstats
path: root/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-kiwisolver/python3-kiwisolver.SlackBuild')
-rw-r--r--python/python3-kiwisolver/python3-kiwisolver.SlackBuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/python/python3-kiwisolver/python3-kiwisolver.SlackBuild b/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
index dc508a2611..d39c213ef2 100644
--- a/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
+++ b/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-kiwisolver
SRCNAM=kiwisolver
-VERSION=${VERSION:-1.4.1}
+VERSION=${VERSION:-1.4.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,7 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root $PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true