summaryrefslogtreecommitdiffstats
path: root/python/python3-isort
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-isort')
-rw-r--r--python/python3-isort/README3
-rw-r--r--python/python3-isort/python3-isort.SlackBuild27
-rw-r--r--python/python3-isort/python3-isort.info12
-rw-r--r--python/python3-isort/slack-desc12
4 files changed, 30 insertions, 24 deletions
diff --git a/python/python3-isort/README b/python/python3-isort/README
index 396cf35a0f..5369c75f88 100644
--- a/python/python3-isort/README
+++ b/python/python3-isort/README
@@ -2,6 +2,3 @@ isort is a Python utility/library to sort imports alphabetically, and
automatically separated into sections. It provides a command line
utility, Python library and plugins for various editors to quickly sort
all your imports.
-
-This Python 3 version of the isort package doesn't contain the command line
-utility. Install Python 2 isort package to get the utility.
diff --git a/python/python3-isort/python3-isort.SlackBuild b/python/python3-isort/python3-isort.SlackBuild
index 04e2475e75..d929624828 100644
--- a/python/python3-isort/python3-isort.SlackBuild
+++ b/python/python3-isort/python3-isort.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-isort
+# Copyright 2022 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2018 Markus Rinne Finland
# All rights reserved.
#
@@ -22,11 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-isort
SRCNAM=isort
-VERSION=${VERSION:-5.7.0}
+VERSION=${VERSION:-5.11.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -72,20 +83,18 @@ find -L . \
python3 setup.py install --root=$PKG
-# Remove isort binary, because it is contained in Python 2 version of isort package.
-rm $PKG/usr/bin/isort
+# Rename isort binary, because it is contained in Python 2 version of isort package.
+mv $PKG/usr/bin/isort $PKG/usr/bin/isort3
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-isort/python3-isort.info b/python/python3-isort/python3-isort.info
index 25a6a18fd7..f830d9c150 100644
--- a/python/python3-isort/python3-isort.info
+++ b/python/python3-isort/python3-isort.info
@@ -1,10 +1,10 @@
PRGNAM="python3-isort"
-VERSION="5.7.0"
+VERSION="5.11.3"
HOMEPAGE="https://timothycrosley.github.io/isort/"
-DOWNLOAD="https://files.pythonhosted.org/packages/a2/f7/f50fc9555dc0fe2dc1e7f69d93f71961d052857c296cad0fb6d275b20008/isort-5.7.0.tar.gz"
-MD5SUM="941d03d2389b0eb091738b4f0ff5e365"
+DOWNLOAD="https://files.pythonhosted.org/packages/e2/43/d99899bfa24a3914f0318536918ab8c91c09350b5482e4e9bb7291840ae3/isort-5.11.3.tar.gz"
+MD5SUM="66fbcee3d4dc83e8e434b1566086f1b1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Markus Rinne"
-EMAIL="markus.ka.rinne@gmail.com"
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python3-isort/slack-desc b/python/python3-isort/slack-desc
index 0b62fc23bd..6aad05d2cd 100644
--- a/python/python3-isort/slack-desc
+++ b/python/python3-isort/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
python3-isort: python3-isort (sort imports alphabetically)
python3-isort:
-python3-isort: isort is a Python utility/library to sort imports alphabetically, and
-python3-isort: automatically separated into sections. It provides a command line
-python3-isort: utility, Python library and plugins for various editors to quickly
-python3-isort: sort all your imports.
+python3-isort: isort is a Python utility/library to sort imports alphabetically,
+python3-isort: and automatically separated into sections. It provides a command
+python3-isort: line utility, Python library and plugins for various editors to
+python3-isort: quickly sort all your imports.
+python3-isort:
+python3-isort: Homepage: https://pycqa.github.io/isort
python3-isort:
-python3-isort: This Python 3 version of the isort package doesn't contain the command
-python3-isort: line utility. Install Python 2 isort package to get the utility.
python3-isort:
python3-isort: