summaryrefslogtreecommitdiffstats
path: root/python/python3-glances
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-glances')
-rw-r--r--python/python3-glances/README39
-rw-r--r--python/python3-glances/python3-glances.SlackBuild93
-rw-r--r--python/python3-glances/python3-glances.info10
-rw-r--r--python/python3-glances/slack-desc19
4 files changed, 161 insertions, 0 deletions
diff --git a/python/python3-glances/README b/python/python3-glances/README
new file mode 100644
index 0000000000..cedeacf97d
--- /dev/null
+++ b/python/python3-glances/README
@@ -0,0 +1,39 @@
+glances is a free (LGPL), cross-platform, curses-based system
+monitoring tool which aims to present a maximum of information in
+a minimum of space, ideally to fit in a classical 80x24 terminal,
+or larger for additional data. It can adapt the displayed information
+dynamically, depending on the terminal size. A client/server mode is
+also available and remote monitoring can be done via terminal or a
+web interface.
+
+glances is written in Python and uses the psutil library to fetch
+statistical values from key elements, like CPU, load average, memory,
+network, disks, file systems, processes, etc.
+
+OPTIONAL DEPENDENCIES
+
+* Available on SBo: python3-docker (for Docker monitoring support)
+elasticsearch (for Elastic Search export module) hddtemp (for HDD
+temperature monitoring support) influxdb (for InfluxDB export module)
+python3-netifaces (for IP plugin) python-prometheus_client (for the
+Prometheus export module) python3-py-cpuinfo (for Quicklook CPU info
+module) python3-pymdstat (for RAID support) python3-pyzmq (for ZeroMQ
+export module)
+
+* Needs python3 version: batinfo (for battery monitoring) bottle
+(for Web server mode) python3-pysnmp (for SNMP support) statsd (for
+StatsD export module)
+
+* Not available on SBo: bernhard (for Riemann export module)
+cassandra-driver (for Cassandra export module) chevron (for the action
+script feature) couchdb (for CouchDB export module) graphitesender
+(For the Graphite export module) kafka-python (for Kafka export
+module) nvidia-ml-pyi3 (for GPU plugin) pika (for RabbitMQ/ActiveMQ
+export module) potsdb (for OpenTSDB export module) pygal (for graph
+export module) pySMART.smartx (for HDD Smart support) sparklines (for
+the Quick Plugin sparklines option) wifi (for wifi plugin) zeroconf
+(for autodiscover mode)
+
+NOTE: When launching glances from a terminal with a bright background,
+the option '--theme-white' is recommended. More options are documented
+in the man page and in the file glances.conf.
diff --git a/python/python3-glances/python3-glances.SlackBuild b/python/python3-glances/python3-glances.SlackBuild
new file mode 100644
index 0000000000..d211b2bebc
--- /dev/null
+++ b/python/python3-glances/python3-glances.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/bash
+
+# Slackware build script for python3-glances
+
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20240323 46and2: Updated version, change to pep517 build.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-glances
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.4.0.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${SRCNAM^}-$VERSION
+tar xvzf $CWD/${SRCNAM^}-$VERSION.tar.gz
+cd ${SRCNAM^}-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+#change location to install man pages
+sed -i 's|share/man|man|g' setup.py
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \+
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+#cleanup usr/share
+rm -rf $PKG/usr/share
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CONTRIBUTING.md COPYING NEWS.rst README.rst conf/${SRCNAM,}.conf \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-glances/python3-glances.info b/python/python3-glances/python3-glances.info
new file mode 100644
index 0000000000..e373c4eb53
--- /dev/null
+++ b/python/python3-glances/python3-glances.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-glances"
+VERSION="3.4.0.5"
+HOMEPAGE="https://github.com/nicolargo/glances"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/g/glances/Glances-3.4.0.5.tar.gz"
+MD5SUM="865998839b2176d385947cfa762e8cf7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-psutil python3-defusedxml python3-ujson"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-glances/slack-desc b/python/python3-glances/slack-desc
new file mode 100644
index 0000000000..a1fb1b1e29
--- /dev/null
+++ b/python/python3-glances/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-glances: python3-glances (cross-platform, curses-based system monitoring tool)
+python3-glances:
+python3-glances: glances is a cross-platform, curses-based system monitoring tool
+python3-glances: written in Python. It can adapt the displayed information depending
+python3-glances: on the terminal size and can work in a client/server mode for remote
+python3-glances: monitoring. It uses the psutil library to fetch statistical values
+python3-glances: from key elements, like CPU, load average, memory, network, disks,
+python3-glances: file systems, processes, etc.
+python3-glances:
+python3-glances: Homepage: https://github.com/nicolargo/glances
+python3-glances: