summaryrefslogtreecommitdiffstats
path: root/python/python3-dogpile.cache
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-dogpile.cache')
-rw-r--r--python/python3-dogpile.cache/README6
-rw-r--r--python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild98
-rw-r--r--python/python3-dogpile.cache/python3-dogpile.cache.info10
-rw-r--r--python/python3-dogpile.cache/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/python/python3-dogpile.cache/README b/python/python3-dogpile.cache/README
new file mode 100644
index 0000000000..3e40e28f6c
--- /dev/null
+++ b/python/python3-dogpile.cache/README
@@ -0,0 +1,6 @@
+python3-dogpile.cache (Caching interface to backends of any variety)
+
+dogpile.cache is a caching API which provides a generic interface
+to caching backends of any variety, and additionally provides API
+hooks which integrate these cache backends with the locking mechanism
+of dogpile.
diff --git a/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild b/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
new file mode 100644
index 0000000000..92b122b07b
--- /dev/null
+++ b/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for python3-dogpile.cache
+
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-dogpile.cache
+VERSION=${VERSION:-1.3.3}
+SRCNAM=${SRCNAM:-dogpile.cache}
+SRCVER=${SRCVER:-rel_$(echo $VERSION | tr . _)}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-dogpile.cache/python3-dogpile.cache.info b/python/python3-dogpile.cache/python3-dogpile.cache.info
new file mode 100644
index 0000000000..be9404d531
--- /dev/null
+++ b/python/python3-dogpile.cache/python3-dogpile.cache.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-dogpile.cache"
+VERSION="1.3.3"
+HOMEPAGE="https://dogpilecache.sqlalchemy.org/"
+DOWNLOAD="https://github.com/sqlalchemy/dogpile.cache/archive/rel_1_3_3/dogpile.cache-rel_1_3_3.tar.gz"
+MD5SUM="3a252847b9d7c7c083786dd9ddf95afa"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-stevedore python3-decorator typing-extensions python3-setuptools-opt"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-dogpile.cache/slack-desc b/python/python3-dogpile.cache/slack-desc
new file mode 100644
index 0000000000..61b0c057ca
--- /dev/null
+++ b/python/python3-dogpile.cache/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-dogpile.cache: python3-dogpile.cache (Caching interface to backends of any variety)
+python3-dogpile.cache:
+python3-dogpile.cache: dogpile.cache is a caching API which provides a generic interface
+python3-dogpile.cache: to caching backends of any variety, and additionally provides API
+python3-dogpile.cache: hooks which integrate these cache backends with the locking mechanism
+python3-dogpile.cache: of dogpile.
+python3-dogpile.cache:
+python3-dogpile.cache: HOMEPAGE: https://dogpilecache.sqlalchemy.org/
+python3-dogpile.cache:
+python3-dogpile.cache:
+python3-dogpile.cache: