summaryrefslogtreecommitdiffstats
path: root/python/python3-cinemagoer
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-cinemagoer')
-rw-r--r--python/python3-cinemagoer/README9
-rw-r--r--python/python3-cinemagoer/python3-cinemagoer.SlackBuild94
-rw-r--r--python/python3-cinemagoer/python3-cinemagoer.info10
-rw-r--r--python/python3-cinemagoer/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/python/python3-cinemagoer/README b/python/python3-cinemagoer/README
new file mode 100644
index 0000000000..7be53fc25d
--- /dev/null
+++ b/python/python3-cinemagoer/README
@@ -0,0 +1,9 @@
+python3-cinemagoer (Retrieve and manage the data of IMDb)
+
+Cinemagoer (previously known as IMDbPY) is a Python package for
+retrieving and managing the data of the IMDb movie database about
+movies, people and companies.
+
+This project and its authors are not affiliated in any way to Internet
+Movie Database Inc.; see the DISCLAIMER.txt file for details about
+data licenses.
diff --git a/python/python3-cinemagoer/python3-cinemagoer.SlackBuild b/python/python3-cinemagoer/python3-cinemagoer.SlackBuild
new file mode 100644
index 0000000000..196d2c8679
--- /dev/null
+++ b/python/python3-cinemagoer/python3-cinemagoer.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Slackware build script for python3-cinemagoer
+
+# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-cinemagoer
+VERSION=${VERSION:-2023.05.01}
+SRCNAM=${SRCNAM:-cinemagoer}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.txt CONTRIBUTORS.txt CREDITS.txt DISCLAIMER.txt LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-cinemagoer/python3-cinemagoer.info b/python/python3-cinemagoer/python3-cinemagoer.info
new file mode 100644
index 0000000000..7197b2c132
--- /dev/null
+++ b/python/python3-cinemagoer/python3-cinemagoer.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-cinemagoer"
+VERSION="2023.05.01"
+HOMEPAGE="https://cinemagoer.github.io/"
+DOWNLOAD="https://github.com/cinemagoer/cinemagoer/archive/refs/tags/2023.05.01/cinemagoer-2023.05.01.tar.gz"
+MD5SUM="b9008009d1aa547b2aa302a3483d41cf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-atomicwrites python3-attrs python3-lxml python3-more-itertools python3-pytest SQLAlchemy python3-tox"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-cinemagoer/slack-desc b/python/python3-cinemagoer/slack-desc
new file mode 100644
index 0000000000..d81e2384d7
--- /dev/null
+++ b/python/python3-cinemagoer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-cinemagoer: python3-cinemagoer (Retrieve and manage the data of IMDb)
+python3-cinemagoer:
+python3-cinemagoer: Cinemagoer (previously known as IMDbPY) is a Python package for
+python3-cinemagoer: retrieving and managing the data of the IMDb movie database about
+python3-cinemagoer: movies, people and companies.
+python3-cinemagoer:
+python3-cinemagoer: This project and its authors are not affiliated in any way to Internet
+python3-cinemagoer: Movie Database Inc.; see the DISCLAIMER.txt file for details about
+python3-cinemagoer: data licenses.
+python3-cinemagoer:
+python3-cinemagoer: HOMEPAGE: https://cinemagoer.github.io/