summaryrefslogtreecommitdiffstats
path: root/python/python3-application
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-application')
-rw-r--r--python/python3-application/README20
-rw-r--r--python/python3-application/python3-application.SlackBuild100
-rw-r--r--python/python3-application/python3-application.info10
-rw-r--r--python/python3-application/slack-desc19
4 files changed, 149 insertions, 0 deletions
diff --git a/python/python3-application/README b/python/python3-application/README
new file mode 100644
index 0000000000..643981cc98
--- /dev/null
+++ b/python/python3-application/README
@@ -0,0 +1,20 @@
+Python bindings for UNIX/POSIX.
+
+This package is a collection of modules that are useful when building
+python applications. Their purpose is to eliminate the need to divert
+resources into implementing the small tasks that every application
+needs to do in order to run successfully and focus instead on the
+application logic itself.
+
+The modules that the application package provides are:
+
+ process - UNIX process and signal management.
+ python - python utility classes and functions.
+ configuration - a simple interface to handle configuration files.
+ log - an extensible system logger for console and syslog.
+ debug - memory troubleshooting and execution timing.
+ system - interaction with the underlying operating system.
+ notification - an application wide notification system.
+ version - manage version numbers for applications and packages.
+
+
diff --git a/python/python3-application/python3-application.SlackBuild b/python/python3-application/python3-application.SlackBuild
new file mode 100644
index 0000000000..98747ad10d
--- /dev/null
+++ b/python/python3-application/python3-application.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-application
+
+# Copyright 2023 Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-application
+VERSION=${VERSION:-3.0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-release-$VERSION
+tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
+cd $PRGNAM-release-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog LICENSE NEWS README examples \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-application/python3-application.info b/python/python3-application/python3-application.info
new file mode 100644
index 0000000000..93285fe3a5
--- /dev/null
+++ b/python/python3-application/python3-application.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-application"
+VERSION="3.0.6"
+HOMEPAGE="https://github.com/AGProjects/python3-application"
+DOWNLOAD="https://github.com/AGProjects/python3-application/archive/release-3.0.6/python3-application-release-3.0.6.tar.gz"
+MD5SUM="c94929c1c147d59f6f1b1f3cf01b401c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-application_2023-09-21@lockywolf.net"
diff --git a/python/python3-application/slack-desc b/python/python3-application/slack-desc
new file mode 100644
index 0000000000..d1efbf28b3
--- /dev/null
+++ b/python/python3-application/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-application: python3-application (Python application library)
+python3-application:
+python3-application: This package is a collection of modules that are useful when building
+python3-application: python applications. Their purpose is to eliminate the need to divert
+python3-application: resources into implementing the small tasks that every application
+python3-application: needs to do in order to run successfully and focus instead on the
+python3-application: application logic itself.
+python3-application:
+python3-application: Homepage: https://github.com/AGProjects/python3-application
+python3-application:
+python3-application: