summaryrefslogtreecommitdiffstats
path: root/python/python-twisted
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-twisted')
-rw-r--r--python/python-twisted/README6
-rw-r--r--python/python-twisted/python-twisted.SlackBuild92
-rw-r--r--python/python-twisted/python-twisted.info10
-rw-r--r--python/python-twisted/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/python-twisted/README b/python/python-twisted/README
deleted file mode 100644
index b5ce41eb91..0000000000
--- a/python/python-twisted/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Twisted is an event-driven networking engine written in Python and licensed
-under the MIT license.
-
-Twisted projects variously support TCP, UDP, SSL/TLS, multicast, Unix
-sockets, a large number of protocols (including HTTP, NNTP, IMAP, SSH,
-IRC, FTP, and others), and much more.
diff --git a/python/python-twisted/python-twisted.SlackBuild b/python/python-twisted/python-twisted.SlackBuild
deleted file mode 100644
index 8675dbf31b..0000000000
--- a/python/python-twisted/python-twisted.SlackBuild
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-twisted
-
-# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012-2018 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-PRGNAM=python-twisted
-SRCNAM=Twisted
-VERSION=${VERSION:-17.9.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE* NEWS* README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-twisted/python-twisted.info b/python/python-twisted/python-twisted.info
deleted file mode 100644
index 32c08d9324..0000000000
--- a/python/python-twisted/python-twisted.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-twisted"
-VERSION="17.9.0"
-HOMEPAGE="https://twistedmatrix.com/"
-DOWNLOAD="https://files.pythonhosted.org/packages/a2/37/298f9547606c45d75aa9792369302cc63aa4bbcf7b5f607560180dd099d2/Twisted-17.9.0.tar.bz2"
-MD5SUM="6dbedb918f0c7288a4c670f59393ecf8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="zope.interface constantly incremental Automat hyperlink"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/python-twisted/slack-desc b/python/python-twisted/slack-desc
deleted file mode 100644
index 1afd6dbe75..0000000000
--- a/python/python-twisted/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-twisted: python-twisted (Python networking engine)
-python-twisted:
-python-twisted: Twisted is an event-driven networking engine written in Python and
-python-twisted: licensed under the MIT license.
-python-twisted:
-python-twisted: Homepage: https://twistedmatrix.com/
-python-twisted:
-python-twisted:
-python-twisted:
-python-twisted:
-python-twisted: