summaryrefslogtreecommitdiffstats
path: root/python/python-transaction
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-transaction')
-rw-r--r--python/python-transaction/README8
-rw-r--r--python/python-transaction/python-transaction.SlackBuild73
-rw-r--r--python/python-transaction/python-transaction.info10
-rw-r--r--python/python-transaction/slack-desc19
4 files changed, 0 insertions, 110 deletions
diff --git a/python/python-transaction/README b/python/python-transaction/README
deleted file mode 100644
index f80fdb9017..0000000000
--- a/python/python-transaction/README
+++ /dev/null
@@ -1,8 +0,0 @@
-This package contains a generic transaction implementation for Python. It
-is mainly used by the ZODB, though.
-
-Note that the data manager API, transaction.interfaces.IDataManager, is
-syntactically simple, but semantically complex. The semantics were not
-easy to express in the interface. This could probably use more work. The
-semantics are presented in detail through examples of a sample data manager
-in transaction.tests.test_SampleDataManager.
diff --git a/python/python-transaction/python-transaction.SlackBuild b/python/python-transaction/python-transaction.SlackBuild
deleted file mode 100644
index d47c3353b6..0000000000
--- a/python/python-transaction/python-transaction.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
-# Copyright 2009 Eric Hameleers <alien@slackware.com>, Eindhoven, Netherlands
-
-# Slackware build script for python-transaction
-
-# Written by Lionel Young <redtricycle@gmail.com>
-
-PRGNAM=python-transaction
-SRCNAM=transaction
-VERSION=${VERSION:-1.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES.txt LICENSE.txt README.txt COPYRIGHT.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-transaction/python-transaction.info b/python/python-transaction/python-transaction.info
deleted file mode 100644
index 177c94dcce..0000000000
--- a/python/python-transaction/python-transaction.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-transaction"
-VERSION="1.0.0"
-HOMEPAGE="https://pypi.python.org/pypi/transaction"
-DOWNLOAD="https://pypi.python.org/packages/source/t/transaction/transaction-1.0.0.tar.gz"
-MD5SUM="10b5d02dcded26f6f265771e6d68fc06"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Lionel Young"
-EMAIL="redtricycle@gmail.com"
diff --git a/python/python-transaction/slack-desc b/python/python-transaction/slack-desc
deleted file mode 100644
index 2d0a163b2d..0000000000
--- a/python/python-transaction/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-transaction: python-transaction (Python Transaction Management)
-python-transaction:
-python-transaction: This is a generic transaction implementation for Python. It
-python-transaction: is mainly used by the ZODB. Note that the data manager API,
-python-transaction: transaction.interfaces.IDataManager, is syntactically simple, but
-python-transaction: semantically complex. The semantics were not easy to express in the
-python-transaction: interface. The semantics are presented in detail through examples
-python-transaction: of a sample data manager in transaction.tests.test_SampleDataManager.
-python-transaction:
-python-transaction:
-python-transaction: Homepage: https://pypi.python.org/pypi/transaction