summaryrefslogtreecommitdiffstats
path: root/python/python-tblib
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-tblib')
-rw-r--r--python/python-tblib/README5
-rw-r--r--python/python-tblib/python-tblib.SlackBuild85
-rw-r--r--python/python-tblib/python-tblib.info10
-rw-r--r--python/python-tblib/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-tblib/README b/python/python-tblib/README
deleted file mode 100644
index ae5cc5abf4..0000000000
--- a/python/python-tblib/README
+++ /dev/null
@@ -1,5 +0,0 @@
-A traceback serialization library that allows you to pickle tracebacks and
-raise exceptions with pickled tracebacks in different processes. This allows
-better error handling when running code over multiple processes (imagine
-multiprocessing, billiard, futures, celery etc). It also parses traceback
-strings and raise with the parsed tracebacks.
diff --git a/python/python-tblib/python-tblib.SlackBuild b/python/python-tblib/python-tblib.SlackBuild
deleted file mode 100644
index 28230a36c2..0000000000
--- a/python/python-tblib/python-tblib.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-tblib
-
-# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-tblib
-VERSION=${VERSION:-1.3.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.rst CHANGELOG.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-tblib/python-tblib.info b/python/python-tblib/python-tblib.info
deleted file mode 100644
index ad48b0ea29..0000000000
--- a/python/python-tblib/python-tblib.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-tblib"
-VERSION="1.3.2"
-HOMEPAGE="https://github.com/ionelmc/python-tblib"
-DOWNLOAD="https://github.com/ionelmc/python-tblib/archive/v1.3.2/python-tblib-1.3.2.tar.gz"
-MD5SUM="79fd0a3f446ba1dc4e92395cfb49a7b9"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="six"
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
diff --git a/python/python-tblib/slack-desc b/python/python-tblib/slack-desc
deleted file mode 100644
index e5201435a5..0000000000
--- a/python/python-tblib/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-tblib: python-tblib (Traceback serialization library)
-python-tblib:
-python-tblib: A traceback serialization library that allows you to pickle tracebacks
-python-tblib: and raise exceptions with pickled tracebacks in different processes.
-python-tblib: This allows better error handling when running code over multiple
-python-tblib: processes (imagine multiprocessing, billiard, futures, celery etc).
-python-tblib: It also parses traceback strings and raise with the parsed tracebacks.
-python-tblib:
-python-tblib: Home page: https://github.com/ionelmc/python-tblib
-python-tblib:
-python-tblib: