summaryrefslogtreecommitdiffstats
path: root/python/python-magick/python-magick.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-magick/python-magick.SlackBuild')
-rw-r--r--python/python-magick/python-magick.SlackBuild19
1 files changed, 3 insertions, 16 deletions
diff --git a/python/python-magick/python-magick.SlackBuild b/python/python-magick/python-magick.SlackBuild
index 1129c7f8fe..ed3e235b23 100644
--- a/python/python-magick/python-magick.SlackBuild
+++ b/python/python-magick/python-magick.SlackBuild
@@ -23,8 +23,8 @@
PRGNAM=python-magick
SRCNAM=PythonMagick
-VERSION=${VERSION:-0.9.8}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.9.12}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -56,7 +56,7 @@ fi
DOCS="ChangeLog LICENSE README"
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -71,19 +71,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Provide all objects in PythonMagick
-patch -p1 < $CWD/patches/__init__-fixup
-
-# Use the default python on the system and fix detection of the python
-# include dir (thanks Gentoo)
-patch -p0 < $CWD/patches/pythonmagick-0.9.1-use_active_python_version.patch
-patch -p0 < $CWD/patches/pythonmagick-0.9.2-fix_detection_of_python_includedir.patch
-
-# We have 1.11.5 so it must suffice
-sed -i "s|1\.12|1.11.5|" configure.ac
-
-autoreconf -fi
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \