summaryrefslogtreecommitdiffstats
path: root/python/python-keyczar
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-keyczar')
-rw-r--r--python/python-keyczar/README5
-rw-r--r--python/python-keyczar/python-keyczar.SlackBuild71
-rw-r--r--python/python-keyczar/python-keyczar.info10
-rw-r--r--python/python-keyczar/slack-desc19
4 files changed, 0 insertions, 105 deletions
diff --git a/python/python-keyczar/README b/python/python-keyczar/README
deleted file mode 100644
index 2c001c051c..0000000000
--- a/python/python-keyczar/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Keyczar is an open source cryptographic toolkit designed to make it easier and
-safer for developers to use cryptography in their applications. Keyczar supports
-authentication and encryption with both symmetric and asymmetric keys.
-
-Optional dependency: simplejson
diff --git a/python/python-keyczar/python-keyczar.SlackBuild b/python/python-keyczar/python-keyczar.SlackBuild
deleted file mode 100644
index 7f5789989d..0000000000
--- a/python/python-keyczar/python-keyczar.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-keyczar
-
-# Copyright 2014-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-keyczar
-VERSION=${VERSION:-0.716}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-keyczar/python-keyczar.info b/python/python-keyczar/python-keyczar.info
deleted file mode 100644
index 8858d0911c..0000000000
--- a/python/python-keyczar/python-keyczar.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-keyczar"
-VERSION="0.716"
-HOMEPAGE="http://www.keyczar.org/"
-DOWNLOAD="https://pypi.python.org/packages/c8/14/3ffb68671fef927fa5b60f21c43a04a4a007acbe939a26ba08b197fea6b3/python-keyczar-0.716.tar.gz"
-MD5SUM="734334a6c5921e39003b68429eee77ae"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyasn1 pycrypto"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/python-keyczar/slack-desc b/python/python-keyczar/slack-desc
deleted file mode 100644
index 2a307452ce..0000000000
--- a/python/python-keyczar/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-keyczar: python-keyczar (cryptographic toolkit)
-python-keyczar:
-python-keyczar: Keyczar is an open source cryptographic toolkit designed to make it
-python-keyczar: easier and safer for developers to use cryptography in their
-python-keyczar: applications. Keyczar supports authentication and encryption with both
-python-keyczar: symmetric and asymmetric keys.
-python-keyczar:
-python-keyczar: Homepage: http://www.keyczar.org/
-python-keyczar:
-python-keyczar:
-python-keyczar: