summaryrefslogtreecommitdiffstats
path: root/python/python-PySnooper
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-PySnooper')
-rw-r--r--python/python-PySnooper/README11
-rw-r--r--python/python-PySnooper/python-PySnooper.SlackBuild26
-rw-r--r--python/python-PySnooper/python-PySnooper.info12
3 files changed, 29 insertions, 20 deletions
diff --git a/python/python-PySnooper/README b/python/python-PySnooper/README
index 87440bc63a..975a6ebb17 100644
--- a/python/python-PySnooper/README
+++ b/python/python-PySnooper/README
@@ -1,7 +1,8 @@
PySnooper is a poor man's debugger for Python.
-PySnooper lets you inspect variables and see which lines are running without
-the need for a debugger, breakpoints or print statements. To use PySnooper, add
-one decorator line to the function you're interested in. You'll get a
-play-by-play log of your function, including which lines ran and when, and
-exactly when local variables were changed.
+PySnooper lets you inspect variables and see which lines are
+running without the need for a debugger, breakpoints or print
+statements. To use PySnooper, add one decorator line to the function
+you're interested in. You'll get a play-by-play log of your function,
+including which lines ran and when, and exactly when local variables
+were changed.
diff --git a/python/python-PySnooper/python-PySnooper.SlackBuild b/python/python-PySnooper/python-PySnooper.SlackBuild
index 137b3f04ae..fa75dbc5c6 100644
--- a/python/python-PySnooper/python-PySnooper.SlackBuild
+++ b/python/python-PySnooper/python-PySnooper.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python-PySnooper
-# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2023 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python-PySnooper
-VERSION=${VERSION:-0.4.2}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=PySnooper
@@ -37,7 +41,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,20 +82,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-PySnooper/python-PySnooper.info b/python/python-PySnooper/python-PySnooper.info
index 8a55c7a9bd..41993b21be 100644
--- a/python/python-PySnooper/python-PySnooper.info
+++ b/python/python-PySnooper/python-PySnooper.info
@@ -1,10 +1,10 @@
PRGNAM="python-PySnooper"
-VERSION="0.4.2"
+VERSION="1.1.1"
HOMEPAGE="https://github.com/cool-RR/PySnooper"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/P/PySnooper/PySnooper-0.4.2.tar.gz"
-MD5SUM="de6f5713112ab7328ae743a0ba02d3a7"
+DOWNLOAD="https://files.pythonhosted.org/packages/e9/82/3f6d0f73c9fd19bf07953d788e34d1c64c766a03e54625bf9fe98d730822/PySnooper-1.1.1.tar.gz"
+MD5SUM="8f64bea7d65ed9c617509ddaff60bba2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"