summaryrefslogtreecommitdiffstats
path: root/python/python-PySnooper/python-PySnooper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-PySnooper/python-PySnooper.SlackBuild')
-rw-r--r--python/python-PySnooper/python-PySnooper.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/python/python-PySnooper/python-PySnooper.SlackBuild b/python/python-PySnooper/python-PySnooper.SlackBuild
index fa75dbc5c6..50a1783cd9 100644
--- a/python/python-PySnooper/python-PySnooper.SlackBuild
+++ b/python/python-PySnooper/python-PySnooper.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-PySnooper
-# Copyright 2023 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2023-2024 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-PySnooper
-VERSION=${VERSION:-1.1.1}
+VERSION=${VERSION:-1.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,6 +82,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "30d" setup.cfg
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \