summaryrefslogtreecommitdiffstats
path: root/python/pyperclip
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyperclip')
-rw-r--r--python/pyperclip/README5
-rw-r--r--python/pyperclip/pyperclip.SlackBuild29
-rw-r--r--python/pyperclip/pyperclip.info6
-rw-r--r--python/pyperclip/slack-desc2
4 files changed, 24 insertions, 18 deletions
diff --git a/python/pyperclip/README b/python/pyperclip/README
index 18b74d81c6..e4e985e3b7 100644
--- a/python/pyperclip/README
+++ b/python/pyperclip/README
@@ -1,6 +1,7 @@
Pyperclip is a cross-platform Python module for copy and paste clipboard
-functions. It works with Python 2 and 3. It currently only handles
-plain text.
+functions. It currently only handles plain text.
+
+Python 3 is a hard dependency. This script does not support Python 2.
For example usage see /usr/doc/pyperclip-$VERSION/README.md
diff --git a/python/pyperclip/pyperclip.SlackBuild b/python/pyperclip/pyperclip.SlackBuild
index 7e1f0ee474..bf05ff2ae1 100644
--- a/python/pyperclip/pyperclip.SlackBuild
+++ b/python/pyperclip/pyperclip.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for pyperclip
-# Copyright 2015-2016, 2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2016, 2018, 2020 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=pyperclip
-VERSION=${VERSION:-1.6.4}
-SRCVERSION=${SRCVERSION:-16b1f5b7ece36a08adc5ddec1ef6b1b0aa9de77f}
+VERSION=${VERSION:-1.7.0}
+SRCVERSION=${SRCVERSION:-943372e295764e18ea2069e1c0615ad286089bda}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -70,12 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,4 +93,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pyperclip/pyperclip.info b/python/pyperclip/pyperclip.info
index 131061dea0..88d6a2c099 100644
--- a/python/pyperclip/pyperclip.info
+++ b/python/pyperclip/pyperclip.info
@@ -1,8 +1,8 @@
PRGNAM="pyperclip"
-VERSION="1.6.4"
+VERSION="1.7.0"
HOMEPAGE="https://github.com/asweigart/pyperclip"
-DOWNLOAD="https://github.com/asweigart/pyperclip/archive/16b1f5b/pyperclip-16b1f5b7ece36a08adc5ddec1ef6b1b0aa9de77f.tar.gz"
-MD5SUM="387c4c59688ee6f49992e8476282b9d4"
+DOWNLOAD="https://github.com/asweigart/pyperclip/archive/943372e/pyperclip-943372e295764e18ea2069e1c0615ad286089bda.tar.gz"
+MD5SUM="7a177f7271d626b339ccae91b8d08db0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/pyperclip/slack-desc b/python/pyperclip/slack-desc
index 67f2cd5e6c..2b35e62152 100644
--- a/python/pyperclip/slack-desc
+++ b/python/pyperclip/slack-desc
@@ -9,7 +9,7 @@
pyperclip: pyperclip (Python copy and paste clipboard functions)
pyperclip:
pyperclip: Pyperclip is a cross-platform Python module for copy and paste
-pyperclip: clipboard functions. It works with Python 2 and 3.
+pyperclip: clipboard functions.
pyperclip:
pyperclip: Home page: https://github.com/asweigart/pyperclip
pyperclip: